geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject Re: Maven2... we are almost there!
Date Mon, 07 Aug 2006 02:48:46 GMT
Ya... the xmlbeans plugin does not really play well with m2 :-(

--jason


On Aug 5, 2006, at 8:43 AM, Jeff Genender wrote:

> This is a small work around...
>
> Jason was awesome enough to copy the nasty classes out into the
> target/clover/classes directory, so by adding that to the src in the
> IDEs, it seems to temporarily fix the problem ;-)
>
> But..I agree...I would like to see us up to 2.2 to not have ot hack  
> this.
>
> Jeff
>
> Aaron Mulder wrote:
>> On 8/5/06, David Jencks <david_jencks@yahoo.com> wrote:
>>> I'm not actually sure that there's a released m2 xmlbeans 2.2 plugin
>>> either, and I'd rather get the poms for xmlbeans 2.2 straightened  
>>> out
>>> properly before there is.  Maybe I can get this process to move  
>>> along
>>> a bit.
>>
>> Effectively, there's not a released xmlbeans 2.0 m2 plugin right?  I
>> thought we had to use the snapshot of the xmlbeans 2.0 plugin to  
>> avoid
>> the crazy dependency issues that result in the first build of an
>> xmlbeans module failing but the second passing.
>>
>> Anyway, I'm happy to abandon the M1 build and go with XMLBeans 2.2.
>>
>> Thanks,
>>     Aaron
>>
>>>>> See http://issues.apache.org/jira/browse/XMLBEANS-120 for this
>>>>> problem
>>>>> and that its fixed ;-)
>>>>>
>>>>> Jeff
>>>>>
>>>>> Jeff Genender wrote:
>>>>>> The mvn eclipse:eclipse has big issues with the xmlbeans  
>>>>>> generated
>>>>>> classes (I wrote a hack in our maven 1 build to deal with this).
>>>>>> Have
>>>>>> you gotten this to work?
>>>>>>
>>>>>> Thanks,
>>>>>>
>>>>>> jeff
>>>>>>
>>>>>> Jason Dillon wrote:
>>>>>>> I have finished merging svkmerge/m2migration to trunk.  Now it
>>>>>>> is time
>>>>>>> for everyone to start using the m2 build... and avoid using the
>>>>>>> m1 build.
>>>>>>>
>>>>>>> I updated the docs here which explain what you must do:
>>>>>>>
>>>>>>>
>>>>>>> http://cwiki.apache.org/GMOxDEV/building-apache-geronimo-with-
>>>>>>> maven-2.html
>>>>>>>
>>>>>>> You should bootstrap at least once.  This is temporary and  
>>>>>>> will be
>>>>>>> removed soon.
>>>>>>>
>>>>>>>  * * *
>>>>>>>
>>>>>>> Please, please, please start using the m2 build.  If for some
>>>>>>> reason you
>>>>>>> end up going back to m1 please let us know so we can fix it.
>>>>>>>
>>>>>>> The last major issue left unresolved (that I am ware of) is 

>>>>>>> the car
>>>>>>> plugins support for geronimo-plugin.xml fluff, which I am
>>>>>>> working on
>>>>>>> resolving.
>>>>>>>
>>>>>>> --jason
>>>>
>>>
>>>


Mime
View raw message