geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Mulder" <ammul...@alumni.princeton.edu>
Subject Re: JPA Plugin patch
Date Thu, 31 Aug 2006 15:34:03 GMT
You need to manually install the Geronimo 1.1 CARs into your local M2
repo.  Unfortunately, the only way to do this is to build the Geronimo
1.1 tag from source or to create them by JARring up the right
directories in a Geronimo 1.1 installation.  Matt Hogstrom has a todo
to put all the Geronimo 1.1 CARs and WARs into a Maven repository, but
it doesn't seem to be real high on his list....  Matt, any ETA?

Thanks,
     Aaron

On 8/31/06, Andrus Adamchik <andrus@objectstyle.org> wrote:
> This one (which to the best of my knowledge corresponds to the final
> release of the spec)
>
> http://people.apache.org/repo/m2-snapshot-repository/org/apache/
> geronimo/specs/geronimo-jpa_3.0_spec/1.0-SNAPSHOT/
>
>
> BTW, are you able to build a functioning plugin? I am getting stuck
> here:
>
> # cd plugins/common
> # mvn install
>
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] load of geronimo/geronimo-gbean-deployer/1.1/car failed
>
> Andrus
>
> On Aug 31, 2006, at 7:22 PM, Aaron Mulder wrote:
>
> > OK, but which JPA spec JAR are you using?  I want to make sure I'm
> > building against "the latest".
> >
> > Thanks,
> >      Aaron
> >
> > On 8/31/06, Andrus Adamchik <andrus@objectstyle.org> wrote:
> >> Hi Aaron,
> >>
> >> finally got time to start poking around JPA plugin. I can compile it
> >> now, but it requires a patch below to build against the latest JPA
> >> spec. Not a big fan of SF issue tracker, so I simply put it on the
> >> web:
> >>
> >> http://people.apache.org/~aadamchik/jpa-plugin-patch.txt
> >>
> >> Andrus
> >>
> >
>
>

Mime
View raw message