geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Mulder" <ammul...@alumni.princeton.edu>
Subject Re: Java 1.4 and JEE 5
Date Tue, 08 Aug 2006 18:10:28 GMT
We're working on a plugin that adds JPA support to web apps (assuming
you started Geronimo in Java 5).  If you can help with the OpenJPA
provider, that would be great.  I think there should be something to
show for this soon.  I'm eagerly awating Jason's fix to the
car-maven-plugin so we can pop a plugin out of a Maven build.  :)

However, it's really only a stopgap measure.  Even to do that much, we
have to work around limitations of the Geronimo deployer (which
doesn't seem to have good handling for letting many deployers all
operate on one module).  So we can fix that in 1.2 or whatever, but
even so, you're right that it would be nice to drop J2SE 1.4 support.

I think the real holdup is CORBA certification.  How's Yoko coming?
Rick, weren't you tracking how close we were to being able to switch
over to it?

Thanks,
     Aaron

On 8/8/06, David Blevins <david.blevins@visi.com> wrote:
> So, doing any JEE 5 work basically requires us to drop JDK 1.4
> support and go JDK 1.5 completely.  The JEE 5 libraries all use
> Generics and Enums and Annotations and just do not run in JDK 1.4.
>
> At some point where going to have to drop 1.4.  I don't know if we're
> there yet, but OpenEJB 3 and Jetty 6 are coming along and OpenJPA is
> here so we're not that far either.
>
> I'm hacking away at some way to allow people to use OpenJPA in their
> apps -- don't know how that will turnout just yet -- and was thinking
> a plugin would be best for that as it wouldn't force Geronimo to go
> JDK 1.5.  We could keep down the plugin path for a while and straddle
> the JEE 5 and JDK 1.4 world for a while.  Maybe eventually we want a
> JEE 5 distribution that consists of these still imaginary plugins and
> still have a JDK 1.4 and J2EE 1.4-only distro.  Maybe we don't want
> two distros and have a single J2EE 1.4/JEE 5 distro that works only
> on JDK 1.5.  Dunno....
>
> What are people's thoughts?  (Don't think we need to decide now, but
> it would be good to start talking/thinking about it)
>
> -David
>
>

Mime
View raw message