geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Jencks (JIRA)" <...@geronimo.apache.org>
Subject [jira] Updated: (GERONIMO-2326) unable to deploy a database pool
Date Tue, 22 Aug 2006 06:46:14 GMT
     [ http://issues.apache.org/jira/browse/GERONIMO-2326?page=all ]

David Jencks updated GERONIMO-2326:
-----------------------------------

    Attachment: GERONIMO-2326.djencks.patch

I worked on the dependencies and may have solved the dependency problems.  I'm having problems
apparently with the portlet deploying a local tx derby db pool and some weird problem with
the portlet getting and empty string for one of the jars deploying a derby xa pool.  I'm attaching
my progress so far as I may not have internet access for a while.

> unable to deploy a database pool
> --------------------------------
>
>                 Key: GERONIMO-2326
>                 URL: http://issues.apache.org/jira/browse/GERONIMO-2326
>             Project: Geronimo
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>    Affects Versions: 1.2, 1.1.2
>            Reporter: Bill Dudney
>         Assigned To: David Jencks
>             Fix For: 1.1.2, 1.2
>
>         Attachments: 2326-deploy-datasource.patch, GERONIMO-2326.djencks.patch
>
>
> Trying to deploy a jdbc datasource leads to a blank screen and the following stack trace
in the log.
> The issue appears to be that URLPatternSpec does not like the URL generated by DatabasePoolPortlet
from the info found in the DatabaseInfo.ALL_DATABASES array.
> java.lang.IllegalArgumentException: Qualifier patterns must be present when first URLPattern
is an exact pattern
> 	at javax.security.jacc.URLPatternSpec.<init>(URLPatternSpec.java:98)
> 	at javax.security.jacc.WebUserDataPermission.<init>(WebUserDataPermission.java:83)
> 	at org.apache.geronimo.tomcat.realm.TomcatGeronimoRealm.hasUserDataPermission(TomcatGeronimoRealm.java:131)
> 	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:460)
> 	at org.apache.geronimo.tomcat.GeronimoStandardContext$SystemMethodValve.invoke(GeronimoStandardContext.java:322)
> 	at org.apache.geronimo.tomcat.valve.GeronimoBeforeAfterValve.invoke(GeronimoBeforeAfterValve.java:31)
> 	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
> 	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
> 	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
> 	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
> 	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
> 	at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:667)
> 	at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
> 	at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
> 	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
> 	at java.lang.Thread.run(Thread.java:552)

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message