geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lin Sun (JIRA)" <j...@apache.org>
Subject [jira] Commented: (GERONIMODEVTOOLS-94) Importing archives with non qualified plans cannot be opened with the editor
Date Thu, 17 Aug 2006 03:03:16 GMT
    [ http://issues.apache.org/jira/browse/GERONIMODEVTOOLS-94?page=comments#action_12428561
] 
            
Lin Sun commented on GERONIMODEVTOOLS-94:
-----------------------------------------

The fix for devtools 94 doesn't work.

I tried to print out the following var plan in ImportDeploymentPlanOperation.java

			plan = runtime.fixGeronimoWebSchema(planFile);
	        	System.out.println("plan 1: " + plan.toString());

Here's the printout:
plan 1: <xml-fragment xmlns:nam="http://geronimo.apache.org/xml/ns/naming-1.1" xmlns:sec="http://geronimo.apache.org/xml/ns/security-1.1"
xmlns:sys="http://geronimo.apache.org/xml/ns/deployment-1.1" xmlns:web="http://geronimo.apache.org/xml/ns/j2ee/web-1.1">
  <sys:environment>
    <sys:moduleId>
      <sys:groupId>samples</sys:groupId>
      <sys:artifactId>cviewer</sys:artifactId>
      <sys:version>1.1</sys:version>
      <sys:type>war</sys:type>
    </sys:moduleId>
    <sys:dependencies/>
    <sys:hidden-classes/>
    <sys:non-overridable-classes/>
  </sys:environment>
  <web:context-root>/cviewer</web:context-root>
</xml-fragment>

Note this is not a valid plan.

I updated the following method in org.apache.geronimo.st.v11.core.GeronimoRuntime and it is
working now (for war file).

	public XmlObject fixGeronimoWebSchema(IFile plan) throws XmlException {
        XmlObject xmlplan = getXmlObject(plan);
        if (plan != null) {
            SchemaConversionUtils.fixGeronimoSchema(xmlplan, GerWebAppDocument.type.getDocumentElementName(),
                    GerWebAppType.type);
            save(xmlplan, plan);
            return xmlplan;
        }
        return null;
	//return SchemaConversionUtils.fixGeronimoSchema(getXmlObject(plan), GerWebAppDocument.type.getDocumentElementName(),
GerWebAppType.type);
	}

Also added the save method back from 1.0 to org.apache.geronimo.st.v11.core.GeronimoRuntime:

	private void save(XmlObject object, IFile file) {
		try {
			object.save(file.getLocation().toFile());
			file.refreshLocal(IFile.DEPTH_ONE, null);
		} catch (IOException e) {
			e.printStackTrace();
		} catch (CoreException e) {
			e.printStackTrace();
		}
	}	

I 'll supply a patch for this tomorrow.  This change needs to be applied for other fixGeronimoXXXSchema
method in GeronimoRuntime.java for both st.v1 and st.v11.   


> Importing archives with non qualified plans cannot be opened with the editor
> ----------------------------------------------------------------------------
>
>                 Key: GERONIMODEVTOOLS-94
>                 URL: http://issues.apache.org/jira/browse/GERONIMODEVTOOLS-94
>             Project: Geronimo-Devtools
>          Issue Type: Bug
>          Components: eclipse-plugin
>    Affects Versions: 1.1.0
>         Environment: Windows XP + AG 1.1 + Devtools 1.1
>            Reporter: Lin Sun
>         Assigned To: Sachin Patel
>
> This looks like a defect. I seem to have forgot to implement support for importing non-qualified
plans for 1.1. (i.e Running SchemaConversionUtil on 1.1 plans).
> On Aug 1, 2006, at 3:00 PM, Lin Sun wrote:
> Hi there,
> Has anyone been able to running jar or ear from within eclipse using the devtools 1.1?
> I have a MDB sample (from confluence) and I managed to get it running using devtools
1.0 within eclipse. However, when I import my jar file in, the openejb-jar.xml cannot be read
by the Geronimo application deployment plan editor. In the past experience, this is a pre-requisite
before I can deploy anything to Geronimo server in Eclipse.
> I also tried to create a dummy EJB project and the default openejb-jar.xml cannot be
opened by the Geronimo application deployment plan editor either. Similar prob with the EAR
project.
> I am wondering if this is a known limitation of the 1.1 version of devtools project?
Seems I can only get war project running...
> Thanks, Lin

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message