geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul McMahan" <paulmcma...@gmail.com>
Subject Re: Error while deploying WAR application
Date Fri, 11 Aug 2006 19:07:18 GMT
JSF should work OK. I was able to install and run the samples from
http://myfaces.apache.org/ in Geronimo 1.0.  I had to make one minor
adjustment to the samples' web.xml before deploying, which was to
remove the <description> elements from the <context-param> and
<init-param> elements.  Looks like you may need to do the same.

If that doesn't work, can you post some more of the stack trace you
see in var/log/geronimo.log when you try to deploy?  The most useful
information is usually embedded a few exceptions deep.

Best wishes,
Paul

On 8/11/06, Malvarez1982 <marceloalvarez1982@gmail.com> wrote:
>
> Thanks Aaron,
>
> Unfortunately, I can't go to the Geronimo 1.1. I have WebSphere Application
> Server Community who is based on Geronimo 1.0. By the other hand, I suspect
> that my problem is because of the use of JSF components. Do you know if JSF
> is supported by Geronimo?
>
> One again, Thanks a lot.
>
>
> Aaron Mulder wrote:
> >
> > Is this for Geronimo 1.1?  If so...
> >
> > Your geronimo-web.xml plan is in the G 1.0 format, so that would
> > probably be the problem.  There's an upgrade tool in the bin/
> > directory that you can use to take the first stab at upgrading this
> > plan to the G 1.1 syntax.  You can also look here:
> >
> > http://chariotsolutions.com/geronimo/geronimo-1.1/web.html
> > http://geronimo.apache.org/schemas-1.1/geronimo-web-1.1.xsd
> >
> > Also, there's probably a more instructive error in the server console
> > or server log at geronimo-1.1/var/log/geronimo.log -- I think the one
> > you quoted is an error in the console when your application doesn't
> > deploy right, it's not the actual underlying error that came up during
> > deployment.  That quirk should be fixed in Geronimo 1.1.1, to be
> > released soon.
> >
> > Thanks,
> >       Aaron
> >
> > On 8/11/06, Malvarez1982 <marceloalvarez1982@gmail.com> wrote:
> >>
> >> Hello,
> >>
> >> I need to deploy a WAR application. I have created a deployment plan, but
> >> I
> >> can't find my mistake. When I try to deploy my application I get the
> >> exception:
> >>
> >> 10:08:11,671 ERROR [PortletInvokerImpl] PortletInvokerImpl.render() -
> >> Error
> >> while dispatching portlet.
> >> javax.portlet.PortletException ...
> >>
> >> My deployment plan (geronimo-web.xml) is:
> >>
> >>
> >> <web-app
> >> xmlns="http://geronimo.apache.org/xml/ns/web-1.0"
> >> xmlns:sys="http://geronimo.apache.org/xml/ns/deployment-1.0"
> >> xmlns:naming="http://geronimo.apache.org/xml/ns/naming-1.0"
> >> xmlns:security="http://geronimo.apache.org/xml/ns/security-1.0"
> >> configId="com/lito/test00"
> >> parentId="geronimo/j2ee-server/1.0/car">
> >>
> >> <context-root>lito</context-root>
> >> <context-priority-classloader>true</context-priority-classloader>
> >>
> >> <naming:resource-ref>
> >> <naming:ref-name>SWITCH_Con</naming:ref-name>
> >> <naming:resource-link>jdbc/SWITCH_Con</naming:resource-link>
> >> </naming:resource-ref>
> >>
> >> <naming:resource-ref>
> >> <naming:ref-name>SWITCH_Conn</naming:ref-name>
> >> <naming:resource-link>jdbc/SWITCH_Conn</naming:resource-link>
> >> </naming:resource-ref>
> >>
> >> </web-app>
> >>
> >>
> >>
> >> My WAR web.xml file is:
> >>
> >>
> >> <!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application
> >> 2.3//EN" "http://java.sun.com/dtd/web-app_2_3.dtd">
> >> <web-app id="WebApp_ID">
> >> <display-name>SWITCH</display-name>
> >> <context-param>
> >> <param-name>com.ibm.ws.jsf.JSP_UPDATE_CHECK</param-name>
> >> <param-value>true</param-value>
> >> <description>Description</context-param>
> >> <context-param>
> >> <param-name>com.ibm.ws.jsf.LOAD_FACES_CONFIG_AT_STARTUP</param-name>
> >> <param-value>true</param-value>
> >> <description></description>
> >> </context-param>
> >> <context-param>
> >> <param-name>crystal_image_uri</param-name>
> >> <param-value>crystalreportviewers11</param-value>
> >> </context-param>
> >> <listener>
> >> <listener-class>com.sun.faces.config.ConfigureListener</listener-class>
> >> </listener>
> >> <servlet id="Servlet_1144596880843">
> >> <servlet-name>JS Resource Servlet</servlet-name>
> >> <servlet-class>
> >> com.ibm.faces.webapp.JSResourceServlet</servlet-class>
> >> <load-on-startup>-1</load-on-startup>
> >> </servlet>
> >>
> >> A lot more of <servlet></servlet> tags....
> >>
> >> <servlet-mapping>
> >> <servlet-name>JS Resource Servlet</servlet-name>
> >> <url-pattern>/.ibmjsfres/*</url-pattern>
> >> </servlet-mapping>
> >>
> >> A lot more of <servlet-mapping></servlet-mapping> tags....
> >>
> >> <welcome-file-list>
> >> <welcome-file>index.html</welcome-file>
> >> <welcome-file>index.htm</welcome-file>
> >> <welcome-file>index.jsp</welcome-file>
> >> <welcome-file>default.html</welcome-file>
> >> <welcome-file>default.htm</welcome-file>
> >> <welcome-file>default.jsp</welcome-file>
> >> </welcome-file-list>
> >> <error-page>
> >> <error-code>404</error-code>
> >> <location>/error.jsp</location>
> >> </error-page>
> >> <taglib>
> >> <taglib-uri>http://jakarta.apache.org/taglibs/datetime-1.0</taglib-uri>
> >> <taglib-location>/WEB-INF/lib/taglibs-datetime.jar</taglib-location>
> >> </taglib>
> >> <taglib>
> >> <taglib-uri>http://jakarta.apache.org/taglibs/string-1.0.1</taglib-uri>
> >> <taglib-location>/WEB-INF/lib/taglibs-string.jar</taglib-location>
> >> </taglib>
> >> <taglib>
> >> <taglib-uri>http://jakarta.apache.org/taglibs/utility</taglib-uri>
> >> <taglib-location>/WEB-INF/lib/utility.jar</taglib-location>
> >> </taglib>
> >> <taglib>
> >> <taglib-uri>http://jakarta.apache.org/taglibs/mailer-1.1</taglib-uri>
> >> <taglib-location>/WEB-INF/lib/taglibs-mailer.jar</taglib-location>
> >> </taglib>
> >> <taglib>
> >> <taglib-uri>/crystal-tags-reportviewer.tld</taglib-uri>
> >> <taglib-location>/WEB-INF/crystal-tags-reportviewer.tld</taglib-location>
> >> </taglib>
> >> <resource-ref id="ResourceRef_1145807649406">
> >> <description>Auto Generated - WDO Datasource connection to
> >> SWITCH</description>
> >> <res-ref-name>SWITCH_Con</res-ref-name>
> >> <res-type>javax.sql.DataSource</res-type>
> >> <res-auth>Container</res-auth>
> >> <res-sharing-scope>Shareable</res-sharing-scope>
> >> </resource-ref>
> >> <resource-ref id="ResourceRef_1155302136328">
> >> <description>Auto Generated - WDO Datasource connection to
> >> SWITCH</description>
> >> <res-ref-name>SWITCH_Conn</res-ref-name>
> >> <res-type>javax.sql.DataSource</res-type>
> >> <res-auth>Container</res-auth>
> >> <res-sharing-scope>Shareable</res-sharing-scope>
> >> </resource-ref>
> >> <login-config>
> >> <auth-method>UNSPECIFIED</auth-method>
> >> </login-config>
> >> </web-app>
> >>
> >>
> >> Can someone help me to create a valid deployment plant for this specific
> >> application please???
> >>
> >> Thanks a lot.
> >>
> >> --
> >> View this message in context:
> >> http://www.nabble.com/Error-while-deploying-WAR-application-tf2091788.html#a5765932
> >> Sent from the Apache Geronimo - Dev forum at Nabble.com.
> >>
> >>
> >
> >
>
> --
> View this message in context: http://www.nabble.com/Error-while-deploying-WAR-application-tf2091788.html#a5767029
> Sent from the Apache Geronimo - Dev forum at Nabble.com.
>
>

Mime
View raw message