geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrus Adamchik <>
Subject Re: JPA plugin (was Re: Java 1.4 and JEE 5)
Date Tue, 08 Aug 2006 18:31:23 GMT
Can't speak for Aaron, but I guess this is not so much the code  
referencing provider-specific API, but configuration including  
provider jars... ant testing that it works of course :-)


On Aug 8, 2006, at 2:26 PM, David Blevins wrote:

> On Aug 8, 2006, at 11:10 AM, Aaron Mulder wrote:
>> On 8/8/06, David Blevins <> wrote:
>>> I'm hacking away at some way to allow people to use OpenJPA in their
>>> apps -- don't know how that will turnout just yet -- and was  
>>> thinking
>>> a plugin would be best for that as it wouldn't force Geronimo to go
>>> JDK 1.5.
>> We're working on a plugin that adds JPA support to web apps (assuming
>> you started Geronimo in Java 5).  If you can help with the OpenJPA
>> provider, that would be great.  I think there should be something to
>> show for this soon.  I'm eagerly awating Jason's fix to the
>> car-maven-plugin so we can pop a plugin out of a Maven build.  :)
> What approach are you taking to get this done?   I was thinking to  
> do App-managed EntityManagers, the EntityManagerFactories looked up  
> through JNDI, and available to both web apps and ejbs.
> You make a note about working on an OpenJPA provider, which makes  
> me wonder.  The way a JPA provider is plugged in is standard, so  
> you shouldn't need to write support for a particular provider.  Any  
> details on why that would be required in the code you're working on?
> Regardless, I'm glad I'm not the only one working on this :)
> -David

View raw message