geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Manu T George (JIRA)" <...@geronimo.apache.org>
Subject [jira] Created: (GERONIMO-2318) Database path validation not present
Date Fri, 11 Aug 2006 07:12:14 GMT
Database path validation not present 
-------------------------------------

                 Key: GERONIMO-2318
                 URL: http://issues.apache.org/jira/browse/GERONIMO-2318
             Project: Geronimo
          Issue Type: Bug
      Security Level: public (Regular issues)
          Components: console
    Affects Versions: 1.1.x
         Environment: All Supported Platforms
            Reporter: Manu T George


On deploying pools referring to derby databases. Deployment is shown to be sucessful but the
pool does not start.

Steps are given below

(1)Logged into Administrative Console.

(2)Clicked "Database Pools".

(3) Next, clicked "Create a new database pool: Using the Geronimo database
pool wizard".

(4)Entered Name of Database Pool: CPRO and Database Type: Derby Embedded.
Then clicked Next.

(5)Thereafter entered the following:-
JDBC Driver Class: org.apache.derby.jdbc.EmbeddedDriver
Driver JAR: org.apache.derby/derby/10.1.2.ibm/jar
DB Username: cpro
DB Password: cpro
Database: c:\cprodb\cprodb_COSMO\csdb
Then clicked Next.

(5)The next screen showed:-
JDBC Connection URL: jdbc:derby:c:cprodbcprodb_COSMOcsdb (This being
incorrect, it was changed to jdbc:derby:c:\cprodb\cprodb_COSMO\csdb).

(6)Driver Status: Loaded successfully

(7)Now clicked "Test Connection". This showed:-
Test Result: Connected to Apache Derby 10.1.2.4

(8)Finally clicked "Deploy" It appears that this step was successful
because:-
(i)The DOS window showed "Deployment completed successfully!"

Even though this happens when we refer to this DB Pool in an application
error occurs.

Thus there is no handling of '\' character in these two fields

Giving '/' instead of '\' solves this issue

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message