geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject Re: [m2 build] unable to deploy remote-deploy-* configs
Date Tue, 18 Jul 2006 18:30:50 GMT
Sweet!

:-)

--jason


On Jul 18, 2006, at 10:13 AM, Prasad Kashyap wrote:

> The remote-deploy-tomcat issue too has been resolved.
>
> Cheers
> Prasad.
>
> On 7/17/06, Prasad Kashyap <goyathlay.geronimo@gmail.com> wrote:
>> This issue has now been resolved.. well almost..  (except for
>> remote-deploy-tomcat).
>>
>> http://issues.apache.org/jira/browse/GERONIMO-2201
>>
>> Cheers
>> Prasad
>>
>> On 7/17/06, Prasad Kashyap <goyathlay.geronimo@gmail.com> wrote:
>> > I am trying to get remote-deploy-jetty and remote-deploy-tomcat
>> > configs into the m2 build and it is failing due to packaging/deploy
>> > error. (Anita, Jason, I did get some info off the patches in G-2067
>> > but that didn't help me too much).
>> >
>> > It fails in 1.2 because the deployer in 1.2 has only the
>> > ServiceBuilder available to it. The same config installs  
>> successfully
>> > in a 1.1 build.  In 1.1, the deployer has ServiceBuilder and
>> > EarConfigBuilder available to it. The latter successfully processes
>> > the remote-deploy's plan and deploys it.
>> >
>> > The EARConfigBuilder is missing in the collection of builders
>> > available to the deployer in 1.2. I'm trying to find out what/ 
>> who puts
>> > the builders in the collection there. If anybody knows, please  
>> speak
>> > up.
>> >
>> >
>> >
>> > Cheers
>> > Prasad
>> >
>>


Mime
View raw message