geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sachin Patel <sppat...@gmail.com>
Subject Re: [Vote] Geronimo Eclipse Plugin v1.1.0
Date Mon, 10 Jul 2006 14:03:27 GMT
Ok thanks for the correction.  So what classifies a veto?

On Jul 10, 2006, at 9:54 AM, Kevan Miller wrote:

>
> On Jul 10, 2006, at 9:07 AM, Sachin Patel wrote:
>
>>
>> On Jul 10, 2006, at 5:16 AM, Jacek Laskowski wrote:
>>
>>> On 7/10/06, Sachin Patel <sppatel2@gmail.com> wrote:
>>>
>>>> No critical reason, just a time frame on when I'll upload the  
>>>> driver to the
>>>> distribution size if no -1's have been casted.
>>>
>>> That's interesting...would that mean that if Geronimo 1.2 is  
>>> about to
>>> release only 72 hours matters or 3+ votes?
>>
>> Is it required that every PMC must vote? If not, then yes, I would  
>> think so.  A released is only stopped if a -1 is received, not if  
>> people abstain from a vote.
>
> No, that's not right. A release is a majority vote. You can't  
> "veto" a release with a -1. And, I think, there's no minimum vote  
> requirement. Although if you only have 3 +1 votes, then I'd say  
> something is probably wrong...  72 hours seems to be considered a  
> minimum vote timeframe... I think we had something similar for some  
> of the G 1.1 release votes...
>
> --kevan
>
>>>
>>>
>>>> The first one just unzips into your ECLIPSE_HOME.  Once  
>>>> released, the second
>>>> is the distribution that gets unzipped into the update manager  
>>>> site.  The
>>>> packaging is a little different.  The second one can also be  
>>>> tested by
>>>> unzipping anywhere on your filesystem and creating a "local"  
>>>> update site to
>>>> it.  The site.xml is not really needed to test it.
>>>>
>>>>
>>>> Which one do I need to download
>>>> and what are the steps to test it out? Just unpack to $ECLIPSE_HOME
>>>> dir? Just downloaded Eclipse 3.2 and am ready to give it a whirl.
>>>>
>>>>
>>>> You can start with Eclipse 3.2 but will need to go to the update  
>>>> manager to
>>>> add WTP and its requirements.  Or you can download the WTP-all  
>>>> in one
>>>> package.  I'm working as-we speak on a eclipse-plugin FAQ for  
>>>> the wiki that
>>>> will contain further detailed info.
>>>
>>> Looking forward to reading it.
>>>
>>> Another question is about the naming - why is the plugin named -
>>> g-eclipse-... nor geronimo-eclipse-...?
>>
>> No reason.  I can rename them.  Keep in mind these zips are not  
>> the primary way of installation and only an alternate, as the  
>> recommended approach to installing is through the update manager.
>>
>>>
>>> Jacek
>>>
>>> -- 
>>> Jacek Laskowski
>>> http://www.laskowski.net.pl
>>
>>
>> -sachin
>>
>>
>


-sachin



Mime
View raw message