geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject Re: m2 error: Configuration already exists...
Date Sat, 01 Jul 2006 20:19:11 GMT
FYI, re-adding the JCL dependency fixes one of the problems...

--jason


On Jul 1, 2006, at 12:17 PM, Jason Dillon wrote:

> This happens during the m2 build... and actually the build ends up  
> cycling between 2 errors, this one and another that is an internal  
> plugin error regarding some JCL classes...
>
> :-(
>
> At least it appears to switch back and forth between these two  
> errors and is not completly random... but still its  _whack_ that  
> the same build fails in different ways on consecutive runs.
>
> I was just running this over and over:
>
>     mvn -o -Dmaven.test.skip=true
>
> (with changes applied from GERONIMO-2161)
>
> --jason
>
>
> On Jul 1, 2006, at 12:08 PM, Jacek Laskowski wrote:
>
>> On 7/1/06, Jason Dillon <jason@planet57.com> wrote:
>>> Is there any reason why a rebuild (with no clean) would cause errors
>>> like this:
>>>
>>> <snip>
>>> [INFO]
>>> -------------------------------------------------------------------- 
>>> ----
>>> [ERROR] BUILD ERROR
>>> [INFO]
>>> -------------------------------------------------------------------- 
>>> ----
>>> [INFO] java.lang.reflect.InvocationTargetException
>>>
>>> Configuration already exists: org.apache.geronimo.configs/rmi- 
>>> naming/
>>> 1.2-SNAPSHOT/car
>>> </snip>
>>
>> Just a guess, isn't Geronimo already populated with the config and
>> thus the error? I believe the script uses deploy nor redeploy. What
>> command did you use? It's M1 build, isn't it?
>>
>>> --jason
>>
>> Jacek
>>
>> -- 
>> Jacek Laskowski
>> http://www.laskowski.net.pl
>


Mime
View raw message