geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject Re: Geronimo Startup Error
Date Sun, 16 Jul 2006 07:57:03 GMT
Should still open an issue.  We have to add a file to tmp to force  
the directory to be created.  The tmp/README.txt explains that some  
versions of WinZip decide to not create empty directories... maybe  
there is a configuration option in WinZip to do that... or maybe some  
versions are just more full of themselves.

Either way... as much as I don't like to have them, I think its  
better to add a README.txt to the directories we expect to exist and  
explain why the files are there... and also what types of files  
should be in that dir etc.

--jason


On Jul 15, 2006, at 8:43 PM, Joe Bohn wrote:

> Michael,
>
> Before you open a JIRA can you please double check this?  I just  
> downloaded both of those files and extracted them using winzip.   
> The empty directories were created.  I've also noticed that when I  
> copy an image I need to be careful to ensure the empty directories  
> are included in the copy.   For example, xcopy * /s won't include  
> the empty directories so you must use the /e option.  I'm not sure  
> if that's what happened on your system but it's happened to me before.
>
> Joe
>
>
> Jason Dillon wrote:
>> Looks like its an oversight... can you please file an issue in Jira:
>>     http://issues.apache.org/jira/browse/GERONIMO
>> Zip can sometimes (annoyingly omit empty directories)... we will  
>> have to put in placeholders to prevent this lame behavior.
>> Anyways, its an easy fix we can get in for 1.1.1
>> --jason
>> On Jul 15, 2006, at 5:25 PM, Michael Malgeri wrote:
>>>
>>> I created empty directories for "var\shared\classes" and "var 
>>> \shared\lib" and the server started up and I was able to log on  
>>> and access the console and poke around.
>>>
>>> I didn't run any other tests like deploying apps, etc.
>>>
>>> I didn't see this in the install notes. Is there a problem with  
>>> the distribution bundles or did I install incorrectly?
>>>
>>> Michael Malgeri
>>> Technical Services Manager
>>> PHONE: 310-727-4544
>>> Tie Line: 286-4544
>>> CELLULAR: 310-704-6403
>>>
>>>
>>> *Michael Malgeri/Los Angeles/IBM*
>>>
>>> 07/15/2006 05:19 PM
>>>
>>> 	
>>> To
>>> 	dev@geronimo.apache.org <mailto:dev@geronimo.apache.org>
>>> cc
>>> 	
>>> Subject
>>> 	Geronimo Startup Error
>>>
>>>
>>> 	
>>>
>>>
>>>
>>>
>>> Hi,
>>>
>>> I downloaded geronimo-tomcat-j2ee-1.1.zip for Windows, ran the  
>>> startup script and got the following error:
>>>
>>> [***************>      ] 70%  20s  Loading geronimo/sharedlib/1.1/ 
>>> car 17:07:15,3
>>> 41 ERROR [GBeanInstanceState] Error while starting; GBean is now  
>>> in the FAILED state: abstractName="geronimo/sharedlib/1.1/car? 
>>> ServiceModule=geronimo/sharedlib/1.1/ 
>>> car,j2eeType=GBean,name=SharedLib"  
>>> java.lang.IllegalArgumentException: Classes dir does not exist: C: 
>>> \AppServers\geronimo-1.1\var\shared\classes
>>>
>>> There's no "..\geronimo-1.1\var\shared\classes" directory in the  
>>> distribution
>>>
>>> Got the same error with Little-G
>>>
>>> Michael Malgeri
>>> Technical Services Manager
>>> PHONE: 310-727-4544
>>> Tie Line: 286-4544
>>> CELLULAR: 310-704-6403


Mime
View raw message