geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Mulder" <ammul...@alumni.princeton.edu>
Subject Can't use car-maven-plugin today!
Date Mon, 31 Jul 2006 16:04:31 GMT
So I tried on a different machine today.

If I specify no version number for car-maven-plugin in the POM, I get:

[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] The plugin 'org.apache.geronimo.plugins:car-maven-plugin' does
not exist or no valid version could be found

If I specify the version 1.2-SNAPSHOT, I get:


[WARNING] Unable to get resource from repository apache-snapshots
(http://people.apache.org/repo/m2-snapshot-repository)
Downloading: http://www.ibiblio.org/maven/org.apache.geronimo.plugins/poms/car-maven-plugin-1.2-SNAPSHOT.pom
[WARNING] Unable to get resource from repository ibiblio-maven-1
(http://www.ibiblio.org/maven)
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

GroupId: org.apache.geronimo.plugins
ArtifactId: car-maven-plugin
Version: 1.2-SNAPSHOT

Reason: Unable to download the artifact from any repository


Indeed, if I look, there is no
org/apache/geronimo/plugins/car-maven-plugin/1.2-SNAPSHOT/car-maven-plugin-1.2-SNAPSHOT.pom
in the Apache snapshot repository
(http://people.apache.org/repo/m2-snapshot-repository)

There is only org/apache/geronimo/plugins/car-maven-plugin/1.2-SNAPSHOT/http://people.apache.org/repo/m2-snapshot-repository/org/apache/geronimo/plugins/car-maven-plugin/1.2-SNAPSHOT/car-maven-plugin-1.2-20060716.224116-1.pom

What's up?  How am I supposed to use the car-maven-plugin when the
version numbers don't match up?

(I'm using Maven 2.0.4 on OS X)

Thanks,
     Aaron

Mime
View raw message