geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shiva Kumar H R" <>
Subject Re: How do we build the Eclipse Plugin assembly?
Date Mon, 03 Jul 2006 06:56:19 GMT
Hi Sachin,
I too am facing the same problem as Donald during the assembly of Eclipse
Plugin. I am building Revision 418691 of the trunk, using Sun JDK 1.4.2_08 &
Maven 2.0.4 on a WinXP sp2 machine.

By the way, I am interested in contributing to Geronimo Eclipse Plugin. Last
year I have done some work on Eclipse Plugin Development and I am
comfortable with SWT, JFace and Plugin Development. Also, some of the work I
did in Eclipse Drag and Drop got published here:

Last one week I have been browsing through the Geronimo Dev Mailing Lists,
as well as JIRA, to figure out how I can contribute to the Eclipse plugin
development. If you can point me to a few to-do items of immediate interest,
I would be more than happy to pick them up and start working on them right

Shiva Kumar

On 7/1/06, Sachin Patel <> wrote:
> You have to invoke it manually as you've done.  I haven't figured out
> how to invoke a build+assembly in one step.  As far as the file sizes
> kevan saw the same problem, and we couldn't figure out why.
> On Jun 30, 2006, at 5:15 PM, Donald Woods wrote:
> > I just checked out Rev418113 of the Eclipse plugin trunk, started
> > with a clean m2 repo and successfully got a "mvn install" to
> > complete after several attempts.
> >
> > But, when I look in the assembly/ directory, no target/ directory
> > was created.  Is this expected?
> >
> > When I ran mvn from the assembly directory, it created a target
> > directory, but the following zipfiles were only 22 bytes each -
> >
> >
> >
> > I'm building on WinXP with Maven 2.0.4 and Sun Java 1.4.2_12-b03.
> >
> >
> > -Donald
> -sachin

View raw message