geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <kevan.mil...@gmail.com>
Subject Re: Corba specs for G 1.2
Date Wed, 19 Jul 2006 02:18:06 GMT

On Jul 18, 2006, at 10:06 PM, Jason Dillon wrote:

> idlj-maven-plugin is the "new" IDL compiler?

No. Both use that plugin. "new" uses the jacorb compiler (i.e.  
<compiler>jacorb</compiler>). "old" uses idlj (i.e. <compiler>idlj</

compiler>).

>
> Where are the sources for the geronimo-spec-corba 1.0 that we are  
> using?  I looked at branches/1_0 and tags/1_0 and I found that the  
> greonimo-spec-corba pom has an artifactId of geronimo-corba_2.3_spec.

Get the bucket out... The "old" corba spec is in geronimo/specs/trunk/ 
geronimo-spec-corba/. Well, technically, the tagged version is in  
geronimo/specs/tags/1_1/geronimo-spec-corba/

--kevan

>
> On Jul 18, 2006, at 6:37 PM, Kevan Miller wrote:
>
>>
>> On Jul 18, 2006, at 6:45 PM, Jason Dillon wrote:
>>
>>> Yikes... what version of the spec is geronimo-spec:geronimo-spec- 
>>> corba:1.0?
>>>
>>> Any idea how to fix specs:geronimo-corba-2.3_spec?
>>
>> The problem with the geronimo-corba-2.3 spec is that it's built  
>> using the "new" IDL compiler. This compiler generated IDL that was  
>> incompatible (i.e. would not work) with the Sun corba  
>> implementation in 1.4. It was more than a TCK problem -- simply  
>> enabling Corba caused the server to fail. I figured out that the  
>> IDL was causing our problems, but didn't have the stomach for  
>> looking at the IDL compiler. So, we went back to using the old- 
>> style spec.
>>
>> As to why we continue to generate corba specs that don't work, I  
>> hope that the Yoko project is finding them useful. Would also hope  
>> that the compiler could be fixed...
>>
>> --kevan
>>
>>> --jason
>>>
>>>
>>> On Jul 18, 2006, at 3:32 PM, Alan D. Cabrera wrote:
>>>
>>>> Jason Dillon wrote:
>>>>> Right now we are using geronimo-spec:geronimo-spec-corba:1.0 in  
>>>>> the m2 build for G 1.2-SNAPSHOT.  This is the only spec that we  
>>>>> are using that has the legacy geronimo-spec groupId.
>>>>>
>>>>> Can we switch this to use one of these:
>>>>>
>>>>>  * org.apache.geronimo.specs:geronimo-corba-2.3_spec:1.1
>>>>>  * org.apache.geronimo.specs:geronimo-corba-3.0_spec:1.1
>>>>>
>>>>> Or, can someone please explain why we have to keep using the  
>>>>> old geronimo-spec:geronimo-spec-corba:1.0 version?
>>>>>
>>>>> --jason
>>>> geronimo-spec:geronimo-spec-corba:1.0 is the "old" jar that we  
>>>> know works w/ the TCK.  The jar  
>>>> org.apache.geronimo.specs:geronimo-corba-2.3_spec:1.1 was tried  
>>>> once but we couldn't get it to pass the TCK.
>>>>
>>>>
>>>> Regards,
>>>> Alan
>>>>
>>>>
>>>
>>
>


Mime
View raw message