geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Dillon (JIRA)" <>
Subject [jira] Commented: (GERONIMO-2082) [m2] stax dependencies are all wrong
Date Mon, 03 Jul 2006 23:55:30 GMT
    [ ] 

Jason Dillon commented on GERONIMO-2082:

GERONIMO-2161 (v4) now addresses part of this problem, which fixes the build, but does not
remove dependencies on stax, etc.

> [m2] stax dependencies are all wrong
> ------------------------------------
>          Key: GERONIMO-2082
>          URL:
>      Project: Geronimo
>         Type: Bug
>     Security: public(Regular issues) 
>     Versions: 1.2
>     Reporter: David Jencks
>     Assignee: David Jencks
>      Fix For: 1.2
>  Attachments: geronimo-no-stax-v2.diff, geronimo-no-stax.diff, m2-repo.jar, openejb-no-stax-v2.diff,
openejb-no-stax.diff, xbean-2.0.0.pom, xmlbeans-maven-plugin-2.0.1-SNAPSHOT.jar, xmlbeans-maven-plugin-2.0.1-SNAPSHOT.jar
> The dependencies for xmlbeans and the maven xmlbeans plugins are all wrong.
> xmlbeans pom needs to depend on stax-api, see
> xmlbeans plugin needs to have stax-api and stax dependencies removed, see
> At this point we can remove all stax and stax-api dependencies from our (and openejb)
> I'll attach the modified xmlbeans pom, the modified plugin, and the patches to remove
all stax mentions from our poms.  I'd appreciate some verification of my results.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message