geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sachin Patel <sppat...@gmail.com>
Subject Re: Errors while using Geronimo Eclipse Plugin RC2
Date Thu, 06 Jul 2006 16:27:49 GMT
As far as the UI problem of the dialog size, can you open a JIRA and  
attach the screen shot to it.  Also since you're the SWT/JFace  
expert :) if I point you to the code, would you be able to provide a  
quick fix?

Thanks.

On Jul 6, 2006, at 10:08 AM, Sachin Patel wrote:

>
> On Jul 6, 2006, at 8:28 AM, Shiva Kumar H R wrote:
>
>> Hi Sachin,
>> I tried using WTP 1.5 and Eclipse 3.2. The problems mentioned  
>> earlier disappear and I am able to start/stop the server  
>> successfully.
>>
>> However after the server gets started, when I right click on the  
>> server, I see that "Launch Geronimo Console" is disabled. Isn't  
>> this a bug? Shall I open a JIRA for the same?
>
> Yes, I noticed this as well, please open a JIRA.
>
>>
>> I also observed that the ".log" file in my "eclipse\workspace 
>> \.metadata" directory has the following messages logged. Do you  
>> suspect any problem here?
>
> No this is ok and just a warning.  I can't remove the duplicate  
> extensions because they are being inserted automatically by EMF  
> during the build.
>
>> --------------------------------------------------------------------- 
>> -------------------------------------------------
>> !SESSION 2006-07-06 17:50: 17.529  
>> -----------------------------------------------
>> eclipse.buildId=M20060629-1905
>> java.version=1.4.2_08
>> java.vendor=Sun Microsystems Inc.
>> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
>> Command-line arguments:  -os win32 -ws win32 -arch x86 -clean
>>
>> !ENTRY org.eclipse.emf.ecore 2 0 2006-07-06 17:50:41.524
>> !MESSAGE Both 'org.apache.geronimo.deployment.model' and  
>> 'org.apache.geronimo.v11.deployment.model' register an extension  
>> parser for 'deployment'
>>
>> !ENTRY org.eclipse.emf.ecore 2 0 2006-07-06 17:50:41.524
>> !MESSAGE Both 'org.apache.geronimo.deployment.model' and  
>> 'org.apache.geronimo.v11.deployment.model' register an extension  
>> parser for 'naming'
>>
>> !ENTRY org.eclipse.emf.ecore 2 0 2006-07-06 17:50:41.534
>> !MESSAGE Both 'org.apache.geronimo.deployment.model' and  
>> 'org.apache.geronimo.v11.deployment.model' register an extension  
>> parser for 'web'
>> --------------------------------------------------------------------- 
>> -------------------------------------------------
>>
>> - Shiva Kumar
>>
>> On 7/5/06, Sachin Patel <sppatel2@gmail.com> wrote: Can you retry  
>> using the callisto release (WTP 1.5, and Eclipse 3.2)?
>> This is what the plugin is built on and supports.
>>
>> On Jul 5, 2006, at 9:05 AM, Shiva Kumar H R wrote:
>>
>> > Hi,
>> > I am using http://people.apache.org/dist/geronimo/eclipse/unstable/
>> > g-eclipse-plugin-1.1-RC2.zip with Eclipse 3.1.2 and WTP 1.0.2
>> > (build  wtp-sdk-R-1.0.2-200604200208).
>> >
>> > 1) While defining a New Server, during this dialog "New Apache
>> > Geronimo v1.1 Runtime: Please enter the directory where Geronimo is
>> > currently installed or where you would like it to be installed." as
>> > shown in attachment " 1.GIF", once I specify the "Application
>> > Server Installation Directory", the upper portion of the Dialog
>> > gets reduced in size leaving me unable to see the message/info
>> > there, as shown in attachment "2.GIF ". Although this doesn't stop
>> > me from defining a new server, I miss out on the information which
>> > was displayed during that dialog.
>> >
>> > 2) After defining the server (I have the following server
>> > installed: Geronimo 1.1 with Jetty with Sun JDK 1.4.2_08), when I
>> > try to start the server, server does get started with the below
>> > messages in "Console" view:
>> >  
>> --------------------------------------------------------------------- 
>> -
>> > -----------------------------------------------------------------
>> > ...
>> > 18:22:49,519 DEBUG [GBeanSingleReference] Waiting to start  
>> geronimo/
>> > remote-deploy-jetty/1.1/car? 
>> J2EEApplication=null,WebModule=geronimo/
>> > remote-deploy-jetty/1.1/car,j2eeType=Servlet,name=jsp because no
>> > targets are running for reference JettyServletRegistration matching
>> > the patterns geronimo/remote-deploy-jetty/1.1/car?
>> > J2EEApplication=null,j2eeType=WebModule,name=geronimo/remote- 
>> deploy-
>> > jetty/1.1/car
>> > 18:22:49,649 DEBUG [GBeanSingleReference] Waiting to start  
>> geronimo/
>> > remote-deploy-jetty/1.1/car? 
>> J2EEApplication=null,WebModule=geronimo/
>> > remote-deploy-jetty/1.1/car,j2eeType=Servlet,name=file-upload
>> > because no targets are running for reference Previous matching the
>> > patterns geronimo/remote-deploy-jetty/1.1/car?
>> > J2EEApplication=null,WebModule=geronimo/remote-deploy-jetty/1.1/
>> > car,j2eeType=Servlet,name=404-error
>> > Geronimo startup complete
>> >  
>> --------------------------------------------------------------------- 
>> -
>> > -----------------------------------------------------------------
>> >
>> > However the "Servers" view still shows the server status as
>> > "Starting.." as shown in attachment " 3.GIF". And after a while, an
>> > Error message "Timeout waiting for Apache Geronimo 1.1 to start.
>> > Server did not start after 240000s." (as shown in attachment
>> > "4.GIF") gets thrown. The ".log" file in "eclipse\workspace
>> > \.metadata" directory has the following messages logged:
>> >  
>> --------------------------------------------------------------------- 
>> -
>> > -----------------------------------------------------------------
>> > !SESSION 2006-07-05 17:53:56.827
>> > -----------------------------------------------
>> > eclipse.buildId=M20060118-1600
>> > java.version=1.4.2_08
>> > java.vendor=Sun Microsystems Inc.
>> > BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
>> > Command-line arguments:  -os win32 -ws win32 -arch x86
>> >
>> > !ENTRY org.eclipse.wst.server.core 4 0 2006-07-05 18:26:00.293
>> > !MESSAGE Timeout waiting for Apache Geronimo 1.1 to start. Server
>> > did not start after 240000s.
>> >  
>> --------------------------------------------------------------------- 
>> -
>> > -----------------------------------------------------------------
>> >
>> > - Shiva Kumar
>> > <1.GIF>
>> > <2.GIF>
>> > <3.GIF>
>> > <4.GIF>
>>
>>
>> -sachin
>>
>>
>>
>>
>
>
> -sachin
>
>


-sachin



Mime
View raw message