geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lin Sun" <>
Subject RE: [Vote] Geronimo Eclipse Plugin v1.1.0
Date Tue, 11 Jul 2006 17:15:56 GMT
I would prefer some statement on the Geronimo server configuration panel to
state that this function is not feature complete and works only with static
html pages.   


This was not clear to me and I am sure others will run into same issues as
well.   I don't think I would want to enable this test environment for now.


P.S I also found out the deploy list-modules output has been changed after I
checked the two checkboxes:


deploy.bat list-modules

Found 39 modules

  + default/eclipse-config-store/1.0/car on


  + geronimo/activemq/1.1/car on


  + geronimo/activemq-broker/1.1/car on




Thanks, Lin


-----Original Message-----
From: Sachin Patel [] On Behalf Of Sachin Patel
Sent: Tuesday, July 11, 2006 8:32 AM
Subject: Re: [Vote] Geronimo Eclipse Plugin v1.1.0


As I mentioned earlier the test environment mode is not feature complete and
it only works in the one scenario I mentioned.


On Jul 10, 2006, at 11:28 PM, Lin Sun wrote:

I started to have problems in deploying my second application which I had it

running with v1.0's plugin.   It is a simple ClassViewer application that

has a jsp and a servlet.  The jsp calls the servlet when user clicks on the

submit button to get the class description.


Upon deployment of the application, I got the following CNP exception when

the two checkboxes (Enable in-place deployment & Run standalone modules

directly from workspace) are checked:


Caused by: 

java.lang.ClassNotFoundException: samples.cviewer.ClassViewerServlet in

classloader samples/cviewer/1.1/war

            at java.lang.Throwable.<init>(

            at java.lang.Throwable.<init>(





            at java.lang.ClassLoader.loadClass(



            ... 84 more


I have gotten this error before

( in v1.0 but I don't

think this is the same prob as I had before this time.   


I noticed that in my project's .classpath file, I have:


<classpathentry path="build/classes" kind="output"/>


However, I don't have the servlet class in that directory.  I tried to

update it to the path where the servlet class is located (ImportedClasses

/samples/cviewer) but still the same error.   


I'll look into more of this but I thought I'd let everyone know since it is

voting time of the plugin.


P.S.  Later on I discovered that the sample works fine when I don't have the

two checkboxes checked.   I can see the servlet and jsp in the good

structure in the repo.  




-----Original Message-----

From: Sachin Patel [] On Behalf Of Sachin Patel

Sent: Sunday, July 09, 2006 4:25 PM


Subject: [Vote] Geronimo Eclipse Plugin v1.1.0


The following distributions of the Geronimo Eclipse plugin are ready  

to be voted on for final release.  Since binding votes are needed,  

each PMC member if possible, please cast your vote within 72 hours.


Here is my +1.


- sachin






View raw message