geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lin Sun" <linsun....@gmail.com>
Subject RE: [Vote] Geronimo Eclipse Plugin v1.1.0
Date Tue, 11 Jul 2006 03:28:19 GMT
I started to have problems in deploying my second application which I had it
running with v1.0's plugin.   It is a simple ClassViewer application that
has a jsp and a servlet.  The jsp calls the servlet when user clicks on the
submit button to get the class description.

Upon deployment of the application, I got the following CNP exception when
the two checkboxes (Enable in-place deployment & Run standalone modules
directly from workspace) are checked:

Caused by: 
java.lang.ClassNotFoundException: samples.cviewer.ClassViewerServlet in
classloader samples/cviewer/1.1/war
	at java.lang.Throwable.<init>(Throwable.java:57)
	at java.lang.Throwable.<init>(Throwable.java:81)
	at
java.lang.ClassNotFoundException.<init>(ClassNotFoundException.java:80)
	at
org.apache.geronimo.kernel.config.MultiParentClassLoader.loadClass(MultiPare
ntClassLoader.java:249)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:561)
	at
org.apache.geronimo.tomcat.GeronimoStandardContext.addChild(GeronimoStandard
Context.java:234)
	... 84 more

I have gotten this error before
(https://bugs.eclipse.org/bugs/show_bug.cgi?id=123803) in v1.0 but I don't
think this is the same prob as I had before this time.   

I noticed that in my project's .classpath file, I have:

<classpathentry path="build/classes" kind="output"/>

However, I don't have the servlet class in that directory.  I tried to
update it to the path where the servlet class is located (ImportedClasses
/samples/cviewer) but still the same error.   

I'll look into more of this but I thought I'd let everyone know since it is
voting time of the plugin.

P.S.  Later on I discovered that the sample works fine when I don't have the
two checkboxes checked.   I can see the servlet and jsp in the good
structure in the repo.  

Lin

-----Original Message-----
From: Sachin Patel [mailto:sppatel2@gmail.com] On Behalf Of Sachin Patel
Sent: Sunday, July 09, 2006 4:25 PM
To: dev@geronimo.apache.org
Subject: [Vote] Geronimo Eclipse Plugin v1.1.0

The following distributions of the Geronimo Eclipse plugin are ready  
to be voted on for final release.  Since binding votes are needed,  
each PMC member if possible, please cast your vote within 72 hours.

http://people.apache.org/dist/geronimo/eclipse/unstable/g-eclipse- 
plugin-1.1-deployable-RC4.zip
http://people.apache.org/dist/geronimo/eclipse/unstable/g-eclipse- 
plugin-1.1-updatesite-RC4.zip

Here is my +1.

- sachin


Mime
View raw message