geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Mulder" <ammul...@alumni.princeton.edu>
Subject Re: Building 1.1-Minimal
Date Sat, 10 Jun 2006 15:12:20 GMT
On 6/10/06, Stefan Arentz <stefan.arentz@gmail.com> wrote:
> I understand that I need to use Java 1.4 for building the full J2EE
> Geronimo. Due to some Corba incompatibilities with 1.5 or so. If I
> just build the minimal profile, can I then do everything with 1.5?

The CORBA problems come up as part of the OpenEJB build.  If you only
check out Geronimo, not OpenEJB, it should download an OpenEJB binary
and I think build fully under 1.5 (including the full J2EE
assemblies).  However, there's not normally a reason to build under
1.5, since you can just build under 1.4 and then run it under 1.5.
(Also, depending on how recent the OpenEJB binary is, it may not work
to just have it download as part of the build.)

> The reason that I'm doing this is that I want to understand for
> example how the jetty-deployer module works. When I search in the svn
> checkout then I only find a deployment plan for this module. Not the
> actual source. And from what I see now during a 'maven new' it looks
> like it just gets binaries for those modules.

The deployment plans are under configs (e.g. configs/jetty-deployer).
The modules are under modules (e.g. modules/jetty-builder).

Thanks,
    Aaron

Mime
View raw message