geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Genender <jgenen...@apache.org>
Subject Re: [RTC] - Fix top pom to reference right plugin
Date Fri, 30 Jun 2006 18:17:19 GMT


David Jencks wrote:
> 
> On Jun 30, 2006, at 10:54 AM, Jeff Genender wrote:
> 
>>
>>
>> Jason Dillon wrote:
>>> FYI, we should be using ${pom.version} anywhere the project version is
>>> needed.  No need for a custom property.
>>
>> I think its by coincidence that we have 1.2-SNAPSHOT for both the plugin
>> and the G codebase...if its not coincidence, then it shouldn't be.
>> IMHO, the plugin should be versioned differently. In fact...I may even
>> go as far as to say, the packaging plugin can be useful outside of
>> geronimo itself (people building their own packages, etc) and probably
>> should be in its own tree or even be a mojo.  I am personally against
>> locking the G verison to the plugin version...I would like to see them
>> seperated.
> 
> Can you explain how this could possibly work since the packaging plugin
> uses geronimo core code to do all its work?  How can it possibly make
> sense to version something that is a way of running some code in maven
> differently than the code that is being run?

Who was the question directed at, me or Jason?

> 
> thanks
> david jencks
> 
>>
>>>
>>> --jason
>>>
>>>
>>> On Jun 30, 2006, at 9:19 AM, David Jencks wrote:
>>>
>>>>
>>>> On Jun 30, 2006, at 9:07 AM, anita kulshreshtha wrote:
>>>>
>>>>>   It was my understanding that we do not use snapshots for plugins.
>>>>> This is from etc/project.properties -
>>>>> geronimo_packaging_plugin_version=1.2.0-4
>>>>> geronimo_assembly_plugin_version=1.2.0-9
>>>>> geronimo_deployment_plugin_version=1.2.0-2
>>>>> geronimo_dependency_plugin_version=1.2.0-2
>>>>
>>>> That was due to maven 1 incompetence in plugin management.  It's
>>>> caused untold headaches.  Although it appears m2 has a whole new set
>>>> of things it cant do with plugins, handling snapshot plugins allegedly
>>>> works fine.  Due to the problems with the m1 versioning I'd like to
>>>> give m2 snapshot plugins a chance.
>>>>
>>>> thanks
>>>> david jencks
>>>>
>>>>>
>>>>> Thnaks
>>>>> Anita
>>>>>
>>>>> --- Jeff Genender <jgenender@savoirtech.com> wrote:
>>>>>
>>>>>> The packaging plugin is at 1.2-SNAPSHOT, and the pom references it
as
>>>>>> 1.2.0. I wan tto update it to 1.2-SNAPSHOT:
>>>>>>
>>>>>> Index: pom.xml
>>>>>> ===================================================================
>>>>>> --- pom.xml     (revision 418149)
>>>>>> +++ pom.xml     (working copy)
>>>>>> @@ -136,7 +136,7 @@
>>>>>>           | Geronimo plugin versions
>>>>>>           |
>>>>>>           -->
>>>>>> -
>>>>>>
>>>>> <geronimoPackagingPluginVersion>1.2.0</geronimoPackagingPluginVersion>
>>>>>> +
>>>>>>
>>>>> <geronimoPackagingPluginVersion>1.2-SNAPSHOT</geronimoPackagingPluginVersion>
>>>>>
>>>>>
>>>>>>
>>>>>>          <!--
>>>>>>           |
>>>>>>
>>>>>
>>>>>
>>>>> __________________________________________________
>>>>> Do You Yahoo!?
>>>>> Tired of spam?  Yahoo! Mail has the best spam protection around
>>>>> http://mail.yahoo.com
>>>>

Mime
View raw message