geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neal Sanche <n...@nsdev.org>
Subject Re: Eclipse Plugin V1.1.0 unstable driver now available
Date Tue, 13 Jun 2006 03:38:29 GMT
You mention, here, that there is a driver available that we can test 
with, is that the one released on June 6th? I am still finding it 
impossible to get that version to start up an deploy to a Geronimo 1.1 
server. It does nearly everything else wonderfully. I've been forced to 
Export .EAR files to the Geronimo 1.1 /deploy directory to test my 
application. Is there anything we can do to get something that at least 
deploys before you get the EMF team to fix a bug in 1.5? I'm perfectly 
happy using 1.0.2 WTP since I tried 1.5 WTP and found that the CMP EJB 
creation is not finished yet. So, since it's the only reason I'd 
consider moving on, I don't see why the Geronimo Eclipse plugin should 
need to yet either.

I haven't seen any movement in the Devtools SVN repository either, so if 
there's a 1.0.2 working version, I don't see it. Am I looking in the 
wrong place?

Thanks Sachin!

Cheers.

-Neal

Sachin Patel wrote:
> They are going fine. The driver that is available should be a good 
> driver to start testing on.  I've been working on moving up to WTP 
> 1.5, EMF 2.2, etc... and have run across a build breaking EMF bug I'm 
> awaiting a fix for.  Hopefully we'll get the fix before EMF 2.2 is 
> released.
>
> On Jun 12, 2006, at 6:43 PM, Jay D. McHugh wrote:
>
>> How are the Eclipse plugin changes going?
>>
>> Jay
>>
>> Sachin Patel wrote:
>>> Hold off on the V11 testing, as I'm finding issues you may run into. 
>>> I'm working on resolving the issues this morning and will let u know 
>>> when I'm done.
>>>
>>> On Jun 7, 2006, at 12:02 AM, Neal Sanche wrote:
>>>
>>>> Okay Sachin,
>>>>
>>>> I have found what I believe to be the main problem. I looked in my 
>>>> Eclipse configuration settings, and found that the Geronimo plugin 
>>>> had a little red X on it indicating it was unhappy. So I looked 
>>>> into why that could be ant found a small complaint it was making:
>>>>
>>>> Plug-in "org.apache.geronimo.st.v11.ui" version "1.0.0" referenced 
>>>> by this feature is missing.
>>>>
>>>> I looked all over and sure enough I do not have a copy of this 
>>>> Jarfile anywhere in my Eclipse directory. Where would I find such a 
>>>> thing? I'm not brave enough to try this build myself at the moment 
>>>> otherwise I would try and make my own version of this. I will see 
>>>> if maybe one of the distributions you posted has it.
>>>>
>>>> -Neal
>>>>
>>>> Sachin Patel wrote:
>>>>> I just posted a new driver. Could you verify that the problem is 
>>>>> fixed?
>>>>>
>>>>> You should be able to just extract over your existing image. Be 
>>>>> sure to re-invoke eclipse with "-clean".
>>>>>
>>>>> Thanks.
>>>>>
>>>>> On Jun 6, 2006, at 9:53 PM, Neal Sanche wrote:
>>>>>
>>>>>> Fair enough,
>>>>>>
>>>>>> I have put in a JIRA, let me know (though the JIRA) what else you

>>>>>> need from me. I am trying out the other features and will see if

>>>>>> I get stuck. I can't start the server from inside Eclipse, but 
>>>>>> maybe I can still develop a small application.
>>>>>>
>>>>>> -Neal
>>>>>>
>>>>>> Sachin Patel wrote:
>>>>>>> I'd have to dig into it, I'm not quite sure looking at just the

>>>>>>> stack trace.
>>>>>>>
>>>>>>> On Jun 6, 2006, at 9:32 PM, Neal Sanche wrote:
>>>>>>>
>>>>>>>> I will put in a JIRA, for sure. Can you tell me what might
be 
>>>>>>>> going on?
>>>>>>>>
>>>>>>>> -Neal
>>>>>>>>
>>>>>>>> Sachin Patel wrote:
>>>>>>>>> Ah shoot, can you open a jira? I can investigate.
>>>>>>>>>
>>>>>>>>> On Jun 5, 2006, at 11:57 PM, Neal Sanche wrote:
>>>>>>>>>
>>>>>>>>>> Sachin Patel wrote:
>>>>>>>>>>> The following driver can run on both JDK 1.4
or 1.5. It 
>>>>>>>>>>> should be run with WTP 1.0x and will eventually
but not 
>>>>>>>>>>> currently run on WTP 1.5.
>>>>>>>>>>>
>>>>>>>>>>> http://people.apache.org/dist/geronimo/eclipse/unstable/g-eclipse-plugin-1.1-SNAPSHOT-deployable.zip

>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> -sachin
>>>>>>>>>>>
>>>>>>>>>> Hi Sachin,
>>>>>>>>>>
>>>>>>>>>> I am currently trying to get Eclipse 1.0.2 All In
One bundle 
>>>>>>>>>> to run your new eclipse plugin with the following
result. I 
>>>>>>>>>> have installed the plugin, and set up a Geronimo
1.1 server 
>>>>>>>>>> that I compiled myself about a week ago. I am going
to try a 
>>>>>>>>>> recompile in the meantime, but what do you think
the 
>>>>>>>>>> following means?
>>>>>>>>>>
>>>>>>>>>> Thanks.
>>>>>>>>>>
>>>>>>>>>> -Neal
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> !ENTRY org.eclipse.osgi 2006-06-05 21:44:07.125
>>>>>>>>>> !MESSAGE An error occurred while automatically activating

>>>>>>>>>> bundle org.apache.geronimo.st.jmxagent (14).
>>>>>>>>>> !STACK 0
>>>>>>>>>> org.osgi.framework.BundleException: The activator

>>>>>>>>>> org.apache.geronimo.st.jmxagent.Activator for bundle

>>>>>>>>>> org.apache.geronimo.st.jmxagent is invalid
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.loadBundleActivator(AbstractBundle.java:149)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:965)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:316)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:264)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.core.runtime.adaptor.EclipseClassLoader.findLocalClass(EclipseClassLoader.java:116)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:337)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.SingleSourcePackage.loadClass(SingleSourcePackage.java:37)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:386)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:350)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.adaptor.core.AbstractClassLoader.loadClass(AbstractClassLoader.java:78)

>>>>>>>>>>
>>>>>>>>>> at java.lang.ClassLoader.loadClass(Unknown Source)
>>>>>>>>>> at java.lang.ClassLoader.loadClassInternal(Unknown
Source)
>>>>>>>>>> at 
>>>>>>>>>> org.apache.geronimo.st.v11.core.GeronimoServerBehaviour.<clinit>(GeronimoServerBehaviour.java:54)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native

>>>>>>>>>> Method)
>>>>>>>>>> at 
>>>>>>>>>> sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown

>>>>>>>>>> Source)
>>>>>>>>>> at 
>>>>>>>>>> sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown

>>>>>>>>>> Source)
>>>>>>>>>> at java.lang.reflect.Constructor.newInstance(Unknown
Source)
>>>>>>>>>> at java.lang.Class.newInstance0(Unknown Source)
>>>>>>>>>> at java.lang.Class.newInstance(Unknown Source)
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:162)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:142)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:129)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:48)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.ServerType.createServerBehaviourDelegate(ServerType.java:91)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.Server.getBehaviourDelegate(Server.java:235)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.Server.setupLaunchConfiguration(Server.java:1059)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.Server.getLaunchConfiguration(Server.java:1118)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.Server.start(Server.java:1139)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.Server.synchronousStart(Server.java:1488)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.StartServerJob.run(StartServerJob.java:34)

>>>>>>>>>>
>>>>>>>>>> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:76)
>>>>>>>>>> Caused by: java.lang.ClassNotFoundException: 
>>>>>>>>>> org.apache.geronimo.st.jmxagent.Activator
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:405)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:350)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.adaptor.core.AbstractClassLoader.loadClass(AbstractClassLoader.java:78)

>>>>>>>>>>
>>>>>>>>>> at java.lang.ClassLoader.loadClass(Unknown Source)
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleLoader.loadClass(BundleLoader.java:275)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:227)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.loadBundleActivator(AbstractBundle.java:142)

>>>>>>>>>>
>>>>>>>>>> ... 30 more
>>>>>>>>>> Root exception:
>>>>>>>>>> java.lang.ClassNotFoundException: 
>>>>>>>>>> org.apache.geronimo.st.jmxagent.Activator
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:405)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:350)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.adaptor.core.AbstractClassLoader.loadClass(AbstractClassLoader.java:78)

>>>>>>>>>>
>>>>>>>>>> at java.lang.ClassLoader.loadClass(Unknown Source)
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleLoader.loadClass(BundleLoader.java:275)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:227)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.loadBundleActivator(AbstractBundle.java:142)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:965)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:316)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:264)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.core.runtime.adaptor.EclipseClassLoader.findLocalClass(EclipseClassLoader.java:116)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:337)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.SingleSourcePackage.loadClass(SingleSourcePackage.java:37)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:386)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:350)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.osgi.framework.adaptor.core.AbstractClassLoader.loadClass(AbstractClassLoader.java:78)

>>>>>>>>>>
>>>>>>>>>> at java.lang.ClassLoader.loadClass(Unknown Source)
>>>>>>>>>> at java.lang.ClassLoader.loadClassInternal(Unknown
Source)
>>>>>>>>>> at 
>>>>>>>>>> org.apache.geronimo.st.v11.core.GeronimoServerBehaviour.<clinit>(GeronimoServerBehaviour.java:54)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native

>>>>>>>>>> Method)
>>>>>>>>>> at 
>>>>>>>>>> sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown

>>>>>>>>>> Source)
>>>>>>>>>> at 
>>>>>>>>>> sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown

>>>>>>>>>> Source)
>>>>>>>>>> at java.lang.reflect.Constructor.newInstance(Unknown
Source)
>>>>>>>>>> at java.lang.Class.newInstance0(Unknown Source)
>>>>>>>>>> at java.lang.Class.newInstance(Unknown Source)
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:162)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:142)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:129)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:48)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.ServerType.createServerBehaviourDelegate(ServerType.java:91)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.Server.getBehaviourDelegate(Server.java:235)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.Server.setupLaunchConfiguration(Server.java:1059)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.Server.getLaunchConfiguration(Server.java:1118)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.Server.start(Server.java:1139)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.Server.synchronousStart(Server.java:1488)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.StartServerJob.run(StartServerJob.java:34)

>>>>>>>>>>
>>>>>>>>>> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:76)
>>>>>>>>>>
>>>>>>>>>> !ENTRY org.eclipse.core.runtime 4 2 2006-06-05 21:44:08.140
>>>>>>>>>> !MESSAGE An internal error occurred during: "Starting
server 
>>>>>>>>>> - Apache Geronimo 1.1".
>>>>>>>>>> !STACK 0
>>>>>>>>>> java.lang.NullPointerException
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.jst.server.generic.core.internal.GenericServerLaunchConfigurationDelegate.launch(GenericServerLaunchConfigurationDelegate.java:51)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:590)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:515)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:152)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.Server.start(Server.java:1140)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.Server.synchronousStart(Server.java:1488)

>>>>>>>>>>
>>>>>>>>>> at 
>>>>>>>>>> org.eclipse.wst.server.core.internal.StartServerJob.run(StartServerJob.java:34)

>>>>>>>>>>
>>>>>>>>>> at org.eclipse.core.internal.jobs.Worker.run(Worker.java:76)
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> -sachin
>>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> -sachin
>>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>> -sachin
>>>>>
>>>>
>>>
>>>
>>> -sachin
>>>
>>>
>>>
>>>
>>>
>>
>
>
> -sachin
>


Mime
View raw message