geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <ja...@planet57.com>
Subject Re: Unable to build using m2
Date Tue, 27 Jun 2006 01:04:59 GMT
FYI, seems that you need to build trunk first (probably until it  
fails with a missing plugin), then build the plugins, then rebuild  
trunk.  Just building m2-plugins pukes with:

<snip>
[INFO]  
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]  
------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

Missing:
----------
1) org.apache.geronimo.modules:geronimo-deploy-tool:jar:1.2-SNAPSHOT

   Try downloading the file manually from the project website.

   Then, install it using the command:
       mvn install:install-file -DgroupId=org.apache.geronimo.modules  
-DartifactId=geronimo-deploy-tool \
           -Dversion=1.2-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file

   Path to dependency:
         1) org.apache.geronimo.plugins:geronimo-packaging- 
plugin:maven-plugin:1.2.0
         2) org.apache.geronimo.modules:geronimo-deploy-tool:jar:1.2- 
SNAPSHOT

2) org.apache.geronimo.modules:geronimo-kernel:jar:1.2-SNAPSHOT

   Try downloading the file manually from the project website.

   Then, install it using the command:
       mvn install:install-file -DgroupId=org.apache.geronimo.modules  
-DartifactId=geronimo-kernel \
           -Dversion=1.2-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file

   Path to dependency:
         1) org.apache.geronimo.plugins:geronimo-packaging- 
plugin:maven-plugin:1.2.0
         2) org.apache.geronimo.modules:geronimo-kernel:jar:1.2-SNAPSHOT

3) org.apache.geronimo.modules:geronimo-service-builder:jar:1.2-SNAPSHOT

   Try downloading the file manually from the project website.

   Then, install it using the command:
       mvn install:install-file -DgroupId=org.apache.geronimo.modules  
-DartifactId=geronimo-service-builder \
           -Dversion=1.2-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file

   Path to dependency:
         1) org.apache.geronimo.plugins:geronimo-packaging- 
plugin:maven-plugin:1.2.0
         2) org.apache.geronimo.modules:geronimo-service-builder:jar: 
1.2-SNAPSHOT

4) org.apache.geronimo.modules:geronimo-system:jar:1.2-SNAPSHOT

   Try downloading the file manually from the project website.

   Then, install it using the command:
       mvn install:install-file -DgroupId=org.apache.geronimo.modules  
-DartifactId=geronimo-system \
           -Dversion=1.2-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file

   Path to dependency:
         1) org.apache.geronimo.plugins:geronimo-packaging- 
plugin:maven-plugin:1.2.0
         2) org.apache.geronimo.modules:geronimo-system:jar:1.2-SNAPSHOT

----------
4 required artifacts are missing.

for artifact:
   org.apache.geronimo.plugins:geronimo-packaging-plugin:maven-plugin: 
1.2.0

from the specified remote repositories:
   central (http://repo1.maven.org/maven2),
   codehaus-dist (http://dist.codehaus.org),
   Apache CVS (http://people.apache.org/maven-snapshot-repository),
   maven1-ibiblio (http://www.ibiblio.org/maven),
   snapshots (http://snapshots.maven.codehaus.org/maven2),
   apache-cvs (http://cvs.apache.org/repository)
</snip>

Looks like bad news... if the main build needs the plugin, and the  
plugin needs the main build, and m2 won't let it all run/build at the  
same time due to its plugin resolution fluff.

May need to provide a bootstrap, which builds a few select modules,  
then the entire system... but that is not very friendly either.

  * * *

Also, start adding <relativePath>../pom.xml</relativePath> to the  
parent element, so that you can skip the mvn -N install bits.

--jason


On Jun 26, 2006, at 1:05 PM, Prasad Kashyap wrote:

> Alan,
>
> You'd have to build the geronimo-packaging-plugin manually first. It's
> under geronimo/m2-plugins
>
> cd geronimo/m2-plugins
> mvn clean
> mvn -N
> mvn
>
> Cheers
> Prasad
>
> On 6/25/06, Alan D. Cabrera <list@toolazydogs.com> wrote:
>> I get this error:
>>
>> Try downloading the file manually from the project website.
>>
>> Then, install it using the command:
>>     mvn install:install-file -DgroupId=org.apache.geronimo.plugins
>> -DartifactId=geronimo-packaging-plugin \
>>         -Dversion=1.2.0 -Dpackaging=maven-plugin -Dfile=/path/to/file
>>
>>
>>   org.apache.geronimo.plugins:geronimo-packaging-plugin:maven- 
>> plugin:1.2.0
>>
>> from the specified remote repositories:
>>   central (http://repo1.maven.org/maven2),
>>   codehaus-dist (http://dist.codehaus.org/mojo/m2-snapshots),
>>   snapshots (http://snapshots.maven.codehaus.org/maven2)
>>
>>   org.apache.geronimo.plugins:geronimo-packaging-plugin:maven- 
>> plugin:1.2.0
>>
>> from the specified remote repositories:
>>   central (http://repo1.maven.org/maven2),
>>   codehaus-dist (http://dist.codehaus.org/mojo/m2-snapshots),
>>   snapshots (http://snapshots.maven.codehaus.org/maven2)
>>
>>
>>
>> Regards,
>> Alan
>>
>>
>>


Mime
View raw message