geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ian.d.stew...@jpmchase.com
Subject Re: Geronimo 1.1 still dependent on Java 1.4.2?
Date Mon, 22 May 2006 19:40:25 GMT
Hi Jim,

I understand that it is possible to run a properly configured instance of
Geronimo using J2SE 5.0.

That being said, the target audience of a Quick Start Guide/Getting Started
document is interested in getting an instance of Geronimo up and running as
quickly as possible.  If a user downloads Geronimo and runs java -jar
bin/server.jar and gets an exception stacktrace (or three) using J2SE 5.0,
and then runs the same command using Java 1.4.2 and does not get a
stacktrace (regardless of whether Geronimo is actually usable or not), then
within that context a dependency exists on Java 1.4.2.

This is what I meant by "out of the box".


Thanks,
Ian

It's better to be hated for who you are
than loved for who you are not

Ian D. Stewart
Appl Dev Analyst-Advisory, DCS Automation
JPMorganChase Global Technology Infrastructure
Phone: (614) 244-2564
Pager: (888) 260-0078


                                                                           
             Jim Jagielski                                                 
             <jim@jaguNET.com>                                             
                                                                        To 
             05/19/2006 08:26          dev@geronimo.apache.org             
             AM                                                         cc 
                                                                           
                                                                   Subject 
             Please respond to         Re: Geronimo 1.1 still dependent on 
             dev@geronimo.apac         Java 1.4.2?                         
                  he.org                                                   
                                                                           
                                                                           
                                                                           
                                                                           
                                                                           





On May 18, 2006, at 11:50 AM, ian.d.stewart@jpmchase.com wrote:

> Dear Developers,
>
> I'm updating the Quick Start guide for Geronimo 1.1
> (http://opensource.atlassian.com/confluence/oss/display/GERONIMO/
> Geronimo+v1.1+-+Quick+start+-+Apache+Geronimo+for+the+impatient).
>   Does Geronimo 1.1 "out of the box" still depend on Java 1.4.2?
>

G does not depend on 1.4.2. You get some error messages
when starting with 1.5.0, but that's due to the Daytrader
app which is bundled with G. Also, CORBA support
only works with 1.4.2, but that's not a G dependency
IMO.



Mime
View raw message