geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sachin Patel <>
Subject Re: Commit configId to moduleId?
Date Sat, 06 May 2006 11:59:50 GMT

- sachin

On May 6, 2006, at 3:24 AM, John Sisson wrote:

> I also was just about to suggest a .module extension, but after  
> further thought, having an extension longer than three characters  
> is likely to reintroduce the filename length issues (under geronimo 
> \repository) on Windows during the builds.
> How about .mod or .mdl.
> John
> Jason Dillon wrote:
>> I'd be happy if we never ended up calling any file a .[a-zA-Z]ar.   
>> I think that the ear/war/rar thing is lame to start with, the  
>> folks that continue to use the same lame extension naming system  
>> (sar, har, dar, car) just perpetuate this silly system that Sun  
>> dropped on us.
>> If we need to use extensions to clarify what something is, then  
>> lets use something more sensible.  Like for a module, why not just  
>> use .module?  If you want to still say its a jar,  
>> then .module.jar, but please lets not make it a .mar.
>> --jason
>> On May 5, 2006, at 7:40 PM, Matt Hogstrom wrote:
>>> Sounds like the consensus is to change it (although I don't  
>>> remember a formal vote although I do remember the discussion).   
>>> For my part it sounds like we're changing the configId to  
>>> moduleId to decrease confusion.  It seems odd that the modules  
>>> are called CARs (Configuration Archives) or some such thing.  I  
>>> think we're making the server more confusing because now less  
>>> things actually line up from a naming perspective.
>>> It just doesn't feel like we're giving our users a lot of stability.
>>> As David said, Just my $0.02.
>>> I would like to see more input from people though.  I've been  
>>> travelling so I must have missed the vote to put it in.
>>> Dain Sundstrom wrote:
>>>> I think now is the time to discuss if we want to commit the  
>>>> change from configId to moduleId.  If we decide to commit the  
>>>> patch, the timing of the actual commit will be determined by  
>>>> Kevan to have the smallest impact on the TCK.  The patch makes  
>>>> the following changes:
>>>>   o Renamed root element from "configuration" to "module"
>>>>   o Renamed environment element from "configId" to "moduleId"
>>>>   o Renamed schema from "geronimo-config-1.1.xsd" to "geronimo- 
>>>> module-1.1.xsd"
>>>> Based on conversations over the past few days, I think we all  
>>>> agree that "configuration" is a poor name choice, and we want to  
>>>> change it.  I also think that we all agree that if we are going  
>>>> to make the change we should change the xml schemas before 1.1  
>>>> ships to have minimal impact on users (we already have schema  
>>>> changes going into 1.1).
>>>> Should we commit?
>>>> -dain

View raw message