geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevan Miller <>
Subject Re: Commit configId to moduleId?
Date Sun, 07 May 2006 14:34:42 GMT

On May 5, 2006, at 3:05 PM, Dain Sundstrom wrote:

> I think now is the time to discuss if we want to commit the change  
> from configId to moduleId.  If we decide to commit the patch, the  
> timing of the actual commit will be determined by Kevan to have the  
> smallest impact on the TCK.  The patch makes the following changes:
>   o Renamed root element from "configuration" to "module"
>   o Renamed environment element from "configId" to "moduleId"
>   o Renamed schema from "geronimo-config-1.1.xsd" to "geronimo- 
> module-1.1.xsd"
> Based on conversations over the past few days, I think we all agree  
> that "configuration" is a poor name choice, and we want to change  
> it.  I also think that we all agree that if we are going to make  
> the change we should change the xml schemas before 1.1 ships to  
> have minimal impact on users (we already have schema changes going  
> into 1.1).
> Should we commit?

OK Dain. We're ready to go.

Here's my understanding of where we are on this issue:

There has been a discussion on the matter (there was no official vote  
-- nor did there need to be one). The consensus was to change  
configId to moduleId.

I didn't participate in the original discussion. For the record, I'm  
neutral on this change. I think we're trading one over-loaded term  
(config) for another (module). Module may be marginally better, but  
not by much... Either way, we end up with terms that will require  

The only outstanding issue is the suffix name for the archive. I've  
heard the following proposals:

1) Leave it as .car
2) Change it to .mod or .mdl
3) Change it to .jar

I believe that 1) is the suffix supported by your patch and is the  
group consensus (albeit not a visibly overwhelming consensus).


View raw message