geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hernan Cunico <hcun...@gmail.com>
Subject Re: Fail to deploy basic web app in 1.1
Date Tue, 30 May 2006 23:34:11 GMT
I zipped the directory HelloWorld containing the WEB-INF and the jsp. If I deploy it to G1.0
with 
the old dep plan it works, same thing in G1.1 (dep plan updated) fails to deploy.

This issue has to be something so simple that we don't see it, at least I don't see it :)

Cheers!
Hernan

Jason Dillon wrote:
> Is this the exact structure of the war?  I'd expect WEB-INF to be 
> top-level:
> 
> HelloWorld.war
>  HelloWorld\HelloWorld.jsp
>  WEB-INF\web.xml
> 
> --jason
> 
> 
> On 5/30/06, Hernan Cunico <hcunico@gmail.com> wrote:
> 
>> it is there! I just double-checked the .war
>>
>> HelloWorld.war
>>    HelloWorld\HelloWorld.jsp
>>    HelloWorld\WEB-INF\web.xml
>>
>> maybe an issue extracting the war?
>>
>> Cheers!
>> Hernan
>>
>> Aaron Mulder wrote:
>> > Oh.  You don't have a WEB-INF/web.xml in the WAR.
>> >
>> > Aaron
>> >
>> > On 5/30/06, Hernan Cunico <hcunico@gmail.com> wrote:
>> >
>> >> I'm using Geronimo/Tomcat. I just tested it with web-1.1 and have the
>> >> same error.
>> >>
>> >> Cheers!
>> >> Hernan
>> >>
>> >> Aaron Mulder wrote:
>> >> > I haven't tried the Tomcat/Jetty namespaces.  Are you using
>> >> > Geronimo/Tomcat not Geronimo/Jetty?  Does it work if you use the
>> >> > web-1.1 namespace?
>> >> >
>> >> > Thanks,
>> >> >    Aaron
>> >> >
>> >> > On 5/30/06, Hernan Cunico <hcunico@gmail.com> wrote:
>> >> >
>> >> >> Hi All,
>> >> >> I am trying to deploy, should I say migrate?, an extremely basic

>> web
>> >> >> app (HelloWorld) from Geronimo
>> >> >> v1.0 to v1.1.  I updated the deployment plan to reflect the latest
>> >> >> changes but the deployer tool
>> >> >> fails to deploy.
>> >> >>
>> >> >> Command I used:
>> >> >> java -jar deployer.jar --user system --password manager deploy
>> >> >> \HelloWorld\HelloWorld.war
>> >> >> \HelloWorld\geronimo-web.xml
>> >> >>
>> >> >> Error received:
>> >> >> Error: Unable to distribute HelloWorld.war: Cannot deploy the
>> >> >> requested application module because no deployer is able to handle
>> >> >> it.  This can happen if you have omitted the J2EE deployment
>> >> >> descriptor, disabled a deployer module, or if, for example, you
are
>> >> >> trying to deploy an EJB module on a minimal Geronimo server that
>> >> >> does not have EJB support installed.
>> >> >> (planFile=E:\HelloWorld\geronimo-web.xml,
>> >> >>
>> >> 
>> moduleFile=E:\geronimo-1.1\var\temp\geronimo-deployer2691.tmpdir\HelloWorld.war)

>>
>> >>
>> >> >>
>> >> >>
>> >> >> Deployment plan geronimo-web.xml:
>> >> >> <?xml version="1.0" encoding="UTF-8"?>
>> >> >> <web-app
>> >> xmlns="http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-1.1">
>> >> >>    <dep:environment
>> >> >> xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.1">
>> >> >>      <dep:moduleId>
>> >> >>        <dep:groupId>geronimo</dep:groupId>
>> >> >>        <dep:artifactId>HelloWorld</dep:artifactId>
>> >> >>        <dep:version>1.1</dep:version>
>> >> >>        <dep:type>war</dep:type>
>> >> >>      </dep:moduleId>
>> >> >>    </dep:environment>
>> >> >>    <context-root>/hello</context-root>
>> >> >> </web-app>
>> >> >>
>> >> >> The .war contains the JSP and WEB-INF\web.xml which, just in 
>> case, I
>> >> >> am attaching too. The build I'm
>> >> >> using is from last Friday.
>> >> >>
>> >> >> Any idea what am I missing?
>> >> >>
>> >> >> Thanks in advance
>> >> >>
>> >> >> Cheers!
>> >> >> Hernan
>> >> >>
>> >> >>
>> >> >>
>> >> >
>> >>
>> >
>>
> 

Mime
View raw message