geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <...@jaguNET.com>
Subject Re: [WARNING] - Mac users
Date Thu, 20 Apr 2006 20:28:44 GMT
On OS X, the java stuff are all symlinks. eg:

     java@ -> /System/Library/Frameworks/JavaVM.framework/Versions/ 
CurrentJDK/Commands/java

So the trick is to adjust the main CurrentJDK symlink in
/System/Library/Frameworks/JavaVM.framework/Versions:

   lrwxr-xr-x   1 root  wheel    5 Apr 20 07:50 1.3@ -> 1.3.1
   drwxr-xr-x   8 root  wheel  272 May 28  2005 1.3.1/
   lrwxr-xr-x   1 root  wheel    5 Sep 14  2005 1.4@ -> 1.4.2
   drwxr-xr-x   8 root  wheel  272 Jan 26  2005 1.4.2/
   lrwxr-xr-x   1 root  wheel    5 Apr 20 07:50 1.5@ -> 1.5.0
   drwxr-xr-x   8 root  wheel  272 Dec  2 11:14 1.5.0/
   drwxr-xr-x   6 root  wheel  204 Apr 20 07:50 A/
   lrwxr-xr-x   1 root  wheel    1 Apr 20 07:50 Current@ -> A
   lrwxr-xr-x   1 root  wheel    5 Apr 20 07:50 CurrentJDK@ -> 1.5.0

A short shell script which adjusts CurrentJDK back and
forth between 1.5.0 and 1.4.2 is all that's needed. The
Java Preferences panel in Utilities doesn't cut it.

On Apr 20, 2006, at 1:19 AM, Jeff Genender wrote:

> Yes...and before anyone asks...
>
> The JVM/JAVA_HOME/PATh was set to the 1.4 JVM.  The OS seems to get
> mixed up about the path libs.
>
> Jeff
>
> Jeff Genender wrote:
>> The last Java 5 update from Apple breaks the Geronimo 1.1 build  
>> for Mac
>> OS X users.
>>
>> Symptoms (when tests are on) include getting the following error:
>>
>> Unable to obtain goal [multiproject:install-callback] --
>> /Users/powerbook/.maven/cache/maven-test-plugin-1.7/plugin.jelly: 
>> 134:-1:
>> <junit> java.lang.NullPointerException
>>
>> or with tests off:
>>
>> The failure will occur in the J2EE Schema module with the  
>> following error:
>>
>> Unable to obtain goal [multiproject:install-callback] --
>> /Users/powerbook/.maven/cache/xmlbeans-maven-plugin-2.0.0-beta1/ 
>> plugin.jelly:83:-1:
>> <xmlbeans:SchemaCompilerWrapper> javax/xml/namespace/QName  
>> (Unsupported
>> major.minor version 49.0)
>>
>> This problem was corroborated by myself, Dain, David Blevins, and  
>> Alan
>> Cabrera.
>>
>> Currently there is no work around, but we are investigating  
>> possible fixes.
>>
>> You are recommended to *NOT* update your Apple JVM at this time.
>>
>> Jeff
>>
>


Mime
View raw message