geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vasily Zakharov (JIRA)" <>
Subject [jira] Updated: (GERONIMO-1841) JMS connector fails to start if <name> is used instead of <gbean-link>
Date Thu, 13 Apr 2006 17:00:00 GMT
     [ ]

Vasily Zakharov updated GERONIMO-1841:

    Attachment: testJMS.xml

Deployment plan that demonstrates the bug

> JMS connector fails to start if <name> is used instead of <gbean-link>
> ----------------------------------------------------------------------
>          Key: GERONIMO-1841
>          URL:
>      Project: Geronimo
>         Type: Bug
>     Security: public(Regular issues) 
>   Components: ActiveMQ
>     Versions: 1.0
>     Reporter: Vasily Zakharov
>     Priority: Minor
>  Attachments: testJMS.xml
> Attached is a JMS connector deployment plan that deploys fine but hangs in a strange
state after that.
> The connector is deployed as follows:
> java -jar bin/deployer.jar --user system --password manager deploy repository/activemq/rars/activemq-ra-3.2.1.rar
> The deployment goes ok (and this probably is a bug).
> At Console/Applications/J2EEConnectors the connector is visible normally, as "running".
> At Console/Services/JMS/JMSDestinationManager the connector's adminObjects are visible
and accessible normally.
> At Console/Services/JMS/JMSConnectionFactories the connector is visible as "Starting"
forever (instead of "Running"), and that surely is a bug.
> When clicking "test connection" on the connector, the following diagnostic appears on
the screen:
> Failed: Operations can only be invoke while the GBean is running: geronimo.server:J2EEApplication=null,J2EEServer=geronimo,JCAResource=TestJMS,j2eeType=JCAManagedConnectionFactory,name=TestConnectionFactory
> When clicking "detail" on the connector, the "Error occurred in portlet!" message appears
on the screen and the exception stack trace appears in the log (stack trace attached).
> The trigger to this strange behaviour is one minor obsoleteness in the deployment plan
- in <workmanager>, the tag <gbean-link> must be used instead of <name>.
If that is changed, the connector starts and operates normally.
> The bug is the connector should either work normally, or fail to deploy with the deployment
plan specifed.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message