geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Blevins <david.blev...@visi.com>
Subject Re: trunk Build failure - can't download a lot of files
Date Tue, 25 Apr 2006 12:36:38 GMT
On Apr 25, 2006, at 5:12 AM, argyn wrote:

> when i try to build with "maven new" command, it fails to download  
> a lot files. apparently, iy is able to download some files. here's  
> an example of failed download:
> ===========
> Attempting to download geronimo-jmxremoting-1.2-SNAPSHOT.jar.
> Error retrieving artifact from [http://cvs.apache.org/repository/ 
> geronimo/jars/geronimo-jmxremoting-
> 1.2-SNAPSHOT.jar]: java.net.ConnectException: Connection timed out:  
> connect
> Artifact /geronimo/jars/geronimo-jmxremoting-1.2-SNAPSHOT.jar  
> doesn't exists in remote repository, b
> ut it exists locally
> ==============
> Unfortunately, some files do not exist localy, so the build fails  
> at the end. If i build with "maven -o new" command, then it fails  
> too. this time it can't find some files again. for example:
> =============
> Copying incubator-activemq/activemq-gbean-management/4.0-SNAPSHOT/jar
>
> BUILD FAILED
> File...... C:\Documents and Settings\argyn\.maven\cache\geronimo- 
> assembly-plugin-1.2.0-8\plugin.jell
> y
> Element... assemble:installConfig
> Line...... 190
> Column.... 145
> Dependency: incubator-activemq/activeio-core/3.0-SNAPSHOT/jar not  
> found in local maven repo: for con
> figuration: geronimo/activemq-broker/1.2-SNAPSHOT/car
> ================
>
> i tried to download some of these files manually and bput in  
> maven's cache. it worked for some. i couldn't find the above file  
> anywhere. also, it's veru inconvinient to look up these files  
> manually.
>
> is something wrong with my configuration? why can't it download  
> files itself? is there any way to configure mirrors?
>
> the strange thing is that if build with "maven" command, it says  
> that build was successfull, but them there's nothing assemblies  
> dir, there's no /bin/server.jar file there.
>

Something is preventing you from connecting to the public maven  
repositories and downloading jars:  "Connection timed out: connect"   
is the big sign of that.

If there is an http proxy between you and the internet, you'll need  
to configure maven's proxy settings.

-David


Mime
View raw message