geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Sisson <jrsis...@gmail.com>
Subject Re: 1.1 Release (Version Upgrades)
Date Tue, 18 Apr 2006 01:07:25 GMT
Currently the 1.1 branch is using activemq 3.2.4-SNAPSHOT.  The activemq 
version should be 3.2.4 (once the activemq 3.2.4 release is finalised).

Hiram and djencks have done some work (including fixes) on the 
activemq-3 branch at:

    svn://svn.activemq.org/activemq/scm/branches/activemq-3

I assume that all the available versions you list containing SNAPSHOTs 
will be changed to a non-SNAPSHOT release.

John

Matt Hogstrom wrote:
> We're nearing the end of the CTS cycle and will soon have a stable 
> 1.1.  Once we reach this critical stage we need to move into the final 
> stages to release 1.1.  Here is my proposed list.
>
> *Starting now:*
> 1. Code freeze for 2006/04/18 23:59 PST (except bug and performance 
> fixes)
>
> *Once we've reached CTS stable:* (feel free to volunteer for tasks)
> 1. Begin changing packages to upgrade as appropriate (proposed list 
> below)
> 2. Develop *Release Notes*
> 3. Draft a *Press Release*
> 4. Begin performance regression
> 5. SWAG a date Release Candidate
> 6. Test, Test, Test
>
> *After 1.1 is stable:*
> 1. Formalize strategy for syncing 1.1 and HEAD
> 2. Define a set of release goals for 1.2 and propose a target date
>    I suggest that we define a theme for a release to help the group 
> focus on a set of goals
>    that will guide the work for the next release.  This is not 
> intended to be a rigid
>    constraint but merely to provide some direction.  It will also help 
> us define a target
>    release date to help us deliver on a consistent schedule for our 
> users.
> 3. Solicit user feedback for prioritizing work
>    Listening to our users and providing them with the features they want.
> 4. Aggressively update our dependent package versions to new new levels.
>
> Cheers,
>
> Matt
>
> *Version Upgrades - Matt's Suggestions*
> I looked at the packages out there and here is the first stab at which 
> ones we should upgrade. Comments?
>
>                               *G*          *Available*
> *Version*   *Package*         *Version*    *Version*
> 1.1         activemq          3.2.1       3.2.3
> 1.1         castor            0.9.5.3      0.9.9.1 or 1.0M3
> 1.1         daytrader         1.1-SNAPSHOT 1.1-SNAPSHOT
> 1.1         derby             10.0.2.1     10.1.2.1
> 1.1         derby             10.1.1.0     10.1.2.1
> 1.1         jasper            5.5.9        5.5.15
> 1.1         jasper            5.5.12       5.5.15
> 1.1         jetty             5.1.9        5.1.10
> 1.1         openejb           2.1-SNAPSHOT 2.1-SNAPSHOT
> 1.1         stax              1.1.1-dev    1.1.2
> 1.1         tomcat            5.5.9        5.5.15
> 1.1         tomcat_ajp        5.5.9        5.5.15
> 1.1         tranql            1.2.1       1.3-SNAPSHOT
> 1.1         tranql_connector  1.1          1.2-SNAPSHOT
>


Mime
View raw message