geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From anita kulshreshtha <a_kuls...@yahoo.com>
Subject Re: Verbiage: Change "configuration" to "module"?
Date Fri, 21 Apr 2006 22:20:17 GMT
+1 
    It is easier to grasp - 
   J2EE module : deployable unit with deployment descriptor
  geronimo module : serialized deployable unit created with a plan

--- Dain Sundstrom <dain@iq80.com> wrote:

> +1 and I think I had a hand in calling them configurations
> 
> I have found people very very confused (blank stares) when I start  
> talking about configurations.
> 
> One issue with this change is it should be reflected in the XML, and 
> 
> console.  This would mean renaming configId in the xml to moduleId,  
> which should be a minor change.


    We will also have to do 'mar' instead of car.

Thnaks
Anita
> 
> -dain
> 
> On Apr 21, 2006, at 1:03 PM, David Blevins wrote:
> 
> > Anything is better than configuration.  I've never liked that term.
> >
> > Module is fine.  Nice term from the apache httpd lexicon.
> >
> > -David
> >
> > On Apr 21, 2006, at 12:54 PM, Aaron Mulder wrote:
> >
> >> All,
> >>
> >> How would you feel about referring to configurations (e.g. a group
> of
> >> GBeans with own ID and classloader) as a "module" instead?  It
> seems
> >> like "configuration" can be confusing, as it more traditionally  
> >> refers
> >> to a larger scope like an entire installation.  For example, if
> you
> >> say you have two different WebLogic configurations or two
> different
> >> Apache (HTTP) configurations, you're saying either you have two
> >> installations, or you have two totally separate product  
> >> configurations
> >> available for the same product installation.  You're not saying
> you
> >> have an app and a database pool within one runtime, but that's
> what
> >> "two different configurations" presently would mean in relation to
> >> Geronimo.
> >>
> >> It seems like it would be clearer to say that a Geronimo
> installation
> >> loads many modules, and each module includes many components  
> >> (GBeans).
> >>
> >> I'm not proposing that we go changing class names and stuff, but
> I'm
> >> proposing that we make a concerted effort in our documentation and
> >> presentations to present the name of the "unit with an ID and
> >> classloader holding many components" as a "module".
> >>
> >> What do you think?
> >>
> >> Thanks,
> >>     Aaron
> >>
> 
> 


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

Mime
View raw message