geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dain Sundstrom <d...@iq80.com>
Subject Re: Release 1.1 - Question about Java 1.5 Warning message
Date Fri, 28 Apr 2006 15:54:46 GMT
On Apr 28, 2006, at 7:48 AM, Paul McMahan wrote:

> e.g. something like:
>
>    <gbean name="RuntimeCheck"
>                  
> class="org.apache.geronimo.system.util.RuntimeCheckGBean">
>        <attribute name="systemProperties">
>            java.runtime.version=1.3,1.4.2
>            os.arch=i386
>            os.name=Linux
>        </attribute>
>        <attribute name="warningText">
>           The runtime environment does not meet the requirements of
> this application:
>           {$systemProperties}
>          Serialization errors and JNI problems may occur.
>        </attribute>
>    </gbean>
>
> Could that be useful to an application like daytrader?  If there's
> interest in this approach (or something similar) then I am happy to
> volunteer.

If you do write that, take a look at  
org.apache.geronimo.kernel.config.Os.

-dain

Mime
View raw message