geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Donald Woods <drw_...@yahoo.com>
Subject Re: Which version of AMQ for geronimo 1.1?
Date Mon, 27 Mar 2006 14:20:01 GMT
We also have the following JIRA issues opened that need changes in 
ActiveMQ to fix -
	G1451 - A new TCP listener for ActiveMQ is not persisting across server 
starups
	G1752 - Changing activeMQ port via console doesn't stick


-Donald

David Jencks wrote:
> Geronimo 1.1 needs some changes in the activemq gbeans in order for  
> activemq to be able to start and be managed by the console.  Which  
> version(s) should I make the modifications in?  Should I make an AMQ  
> branch for this?
> 
> The problems I've identified so far are:
> 
> - The management helper gbean needs extensive modifications to use  
> AbstractNames rather than ObjectNames.
> 
> - The JDBCPersistenceAdapterGBean uses an AMQ interface in its  
> reference to dataSource: this no longer works as we now check that a  
> target gbean declares the interface you ask for in a reference.
> 
> Thanks
> david jencks
> 
> 
> 

Mime
View raw message