geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan D. Cabrera" <>
Subject Re: Thoughts on renaming util module
Date Thu, 23 Mar 2006 17:05:01 GMT
Aaron Mulder wrote, On 3/23/2006 7:07 AM:

>On 3/23/06, Rick McGuire <> wrote:
>>The "random Geromino" code is all part of the original bounycastle
>>import, I believe.
>That's not entirely correct -- there's our utility classes for
>encrypting passwords in config files and I have some
>soon-to-be-committed changes adding certificate helper code like
>generating a formatted fingerprint (MD5 hash).
>>The code that is in this package is all of the bits from bouncycastle
>>necessary to support the asn1 functions required by openejb.  Anything
>>not in the asn1 subdir is just a class needed by the asn1 code, so
>>perhaps a better package name would be asn1 (with some appropriate
>But it's also used by our keystore implementation, which is (or should
>be) fundamental to any SSL networking in the web container, EJB
>container, JMS, etc., etc., etc.  I am also in the process of making
>the keystore logic more central to Geronimo and moving toward a
>central service that will provide SSL server socket factories, and
>that will all leverage this library, so between the password
>encryption and that, I don't terribly fancy calling it ASN1.

Crytpo works for me.  The ASN1 code is solely for the crypto support.  
Hiding that stuff there is a good idea imo.


View raw message