geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick McGuire <>
Subject Re: Thoughts on renaming util module
Date Thu, 23 Mar 2006 14:52:53 GMT
Aaron Mulder wrote:
> Starting an e-mail thread aside from the JIRA...
> I would *really* like to rename the util module.  It's got our
> bouncycastle import, plus some random Geronimo code dealing with
> encryption and certificates.
The "random Geromino" code is all part of the original bounycastle 
import, I believe.

> I believe the best name for it is "crypto".  John pointed out that
> that isn't the greatest name since ASN1 and encoders such as Base64
> aren't necessarily crypto.  But this package deals with encryption,
> decryptions, digests, PKI and certificates, etc.  The bouncycastle
> mailing lists are dev-crypto and accounce-crypto.  I think the
> "crypto" name, even if not perfect, fits much better than the "util"
> name (which to me implies a general utility library like String
> utilities, etc.).  If necessary, I'd go as far as moving encoders to
> the common module just to be able to give this one a better name,
> because it does seem quite focused to me and not at all general.
I think I'd be in favor of that, or leaving the encoders/decoders in 
util and splitting off the rest of the package.  I see a lot more 
general-purpose use for the encoders that for the rest of the package.  
I'm not sure "crypto" is the best name for this package, because this is 
really higher level functions above the actual crypto support.  The 
imported code doesn't directly implement any crypto functions, but it 
definitely takes advantage of it (even the files in the "crypto" 
subpackage don't really have anything directly to do with 
cryptography...they're just interface classes).

The code that is in this package is all of the bits from bouncycastle 
necessary to support the asn1 functions required by openejb.  Anything 
not in the asn1 subdir is just a class needed by the asn1 code, so 
perhaps a better package name would be asn1 (with some appropriate 

> Could we get more thoughts on this?
> Thanks,
>     Aaron

View raw message