geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vamsavardhana Reddy" <c1vams...@gmail.com>
Subject Re: Thoughts on renaming util module
Date Thu, 23 Mar 2006 14:38:46 GMT
"crypto" should be ok.  Though ASN1, Base64 etc aren't necessarily crypto,
they are mostly used when dealing with crypto related stuff.

-Vamsi

On 3/23/06, Aaron Mulder <ammulder@alumni.princeton.edu> wrote:
>
> Starting an e-mail thread aside from the JIRA...
>
> I would *really* like to rename the util module.  It's got our
> bouncycastle import, plus some random Geronimo code dealing with
> encryption and certificates.
>
> I believe the best name for it is "crypto".  John pointed out that
> that isn't the greatest name since ASN1 and encoders such as Base64
> aren't necessarily crypto.  But this package deals with encryption,
> decryptions, digests, PKI and certificates, etc.  The bouncycastle
> mailing lists are dev-crypto and accounce-crypto.  I think the
> "crypto" name, even if not perfect, fits much better than the "util"
> name (which to me implies a general utility library like String
> utilities, etc.).  If necessary, I'd go as far as moving encoders to
> the common module just to be able to give this one a better name,
> because it does seem quite focused to me and not at all general.
>
> Could we get more thoughts on this?
>
> Thanks,
>     Aaron
>

Mime
View raw message