geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacek Laskowski" <eljo...@gmail.com>
Subject Re: Clean build of Geronimo under m2
Date Sat, 18 Mar 2006 23:13:21 GMT
2006/3/18, Henri Yandell <flamefew@gmail.com>:
> I hit a basic problem trying to do a clean build. The specs trunk
> works fine, but the main trunk dies at random intervals due to
> timeouts against the apache.org repositories (I think it's those).
>
> Anyone else having the same problem?

I always build offline so I can't see them happening on my laptop. I
have however found another issue while building Geronimo using M2:

[INFO] [xmlbeans:xmlbeans {execution: default}]
IO Error java.net.UnknownHostException: www.ibm.com
[INFO] ----------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ----------------------------------------------------------------------------
[INFO] XmlBeans compile failed:
 xml ErrorLoading schema file
c:\oss\geronimo\modules\j2ee-schema\src\j2ee_1_4schema\application_1_4.xsd
xml ErrorLoading schema file
c:\oss\geronimo\modules\j2ee-schema\src\j2ee_1_4schema\j2ee_jaxrpc_mapping_1_1.xsd
xml ErrorLoading schema file
c:\oss\geronimo\modules\j2ee-schema\src\j2ee_1_3schema\connector_1_0.xsd
xml ErrorLoading schema file
c:\oss\geronimo\modules\j2ee-schema\src\j2ee_1_4schema\j2ee_1_4.xsd
xml ErrorLoading schema file
c:\oss\geronimo\modules\j2ee-schema\src\j2ee_1_4schema\connector_1_5.xsd
xml ErrorLoading schema file
c:\oss\geronimo\modules\j2ee-schema\src\j2ee_1_4schema\ejb-jar_2_1.xsd
xml ErrorLoading schema file
c:\oss\geronimo\modules\j2ee-schema\src\j2ee_1_4schema\web-app_2_4.xsd
xml ErrorLoading schema file
c:\oss\geronimo\modules\j2ee-schema\src\j2ee_1_4schema\application-client_1_4.xsd
xml ErrorLoading schema file
c:\oss\geronimo\modules\j2ee-schema\src\j2ee_1_4schema\j2ee_web_services_1_1.xsd
xml ErrorLoading config file
c:\oss\geronimo\modules\j2ee-schema\src\conf\xmlconfig.xml
xml Errorc:\oss\geronimo\modules\j2ee-schema\src\j2ee_1_4schema\j2ee_1_4.xsd:76:
error: java.net.UnknownHostException: www.ibm.com
xml ErrorLoading referenced file j2ee_1_4schema/jsp_2_0.xsd
xml Errorc:\oss\geronimo\modules\j2ee-schema\src\j2ee_1_4schema\j2ee_1_4.xsd:707:
error: src-resolve: model group
'service-refGroup@http://java.sun.com/xml/ns/j2ee' not fou
nd.
xml Errorc:\oss\geronimo\modules\j2ee-schema\src\j2ee_1_4schema\j2ee_1_4.xsd:707:
error: src-resolve: model group
'service-refGroup@http://java.sun.com/xml/ns/j2ee' not fou
nd.
xml Errorc:\oss\geronimo\modules\j2ee-schema\src\j2ee_1_4schema\j2ee_1_4.xsd:707:
error: src-resolve: model group
'service-refGroup@http://java.sun.com/xml/ns/j2ee' not fou
nd.
xml Errorc:\oss\geronimo\modules\j2ee-schema\src\j2ee_1_4schema\j2ee_1_4.xsd:707:
error: src-resolve: model group
'service-refGroup@http://java.sun.com/xml/ns/j2ee' not fou
nd.
xml Errorc:\oss\geronimo\modules\j2ee-schema\src\j2ee_1_4schema\application-client_1_4.xsd:215:
error: src-resolve: model group
'service-refGroup@http://java.sun.com/xml/ns
/j2ee' not found.

It happened while I was offline (= with no connection to the Net
rather than offline in the sense of M2). Don't know what to do with it
yet.

> Things are good if I turn those off (except for the various parts of
> Geronimo that are not built against released transitives - directory
> seemed to unfix itself, so the fix must have been overwritten
> somehow).

What error message do you see?

> Hen

Jacek

--
Jacek Laskowski
http://www.laskowski.org.pl

Mime
View raw message