geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prasad Kashyap <goyathlay.geron...@gmail.com>
Subject Re: itests subproject using M2
Date Mon, 13 Feb 2006 23:57:55 GMT
Sorry Vincent. I wasn't more clear there. v0.7 does support Jetty but
not 5.x version of Jetty that Geronimo needs.

But it is good to know that v0.8 does support Jetty 5.x and doesn't
have a requirement on JDK 1.5 either. Awesome, I'll play with the
snapshot now.

Cheers
Prasad

On 2/13/06, Vincent Massol <vmassol@pivolis.com> wrote:
>
>
> > -----Original Message-----
> > From: Prasad Kashyap [mailto:goyathlay.geronimo@gmail.com]
> > Sent: lundi 13 février 2006 23:40
> > To: jason@maven.org
> > Cc: dev@geronimo.apache.org
> > Subject: itests subproject using M2
>
> [snip]
>
> > For now we can't use the maven-cargo-plugin (v0.7) because it doesn't
> > support Jetty container.
>
> v0.7 supports Jetty 4.x but not 5.x nor 6.x.
> v0.7 supports Tomcat 5.0.x and Tomcat 5.5.x.
>
> > After our conversation, I learnt from Vincent
> > that v0.8 plugin of Cargo supports Jetty 5.x and Tomcat 6.x too.
>
> It's Jetty 6.x. I don't think Tomcat 6.x exists yet :-)
>
> > (http://www.mail-archive.com/dev@geronimo.apache.org/msg17658.html)  I
> > need to verify if that doesn't impose a requirement of JDK 1.5 for
> > Jetty goals.
>
> It doesn't.
>
> > G isn't ready to use JDK 1.5 yet. So until then, we'll
> > continue to use our homegrown geronimo-deployment-plugin which I have
> > now ported for m2. I'll look into modifying it to have the same
> > configuration parameters as Cargo so that we can swap out the plugins
> > when Cargo and G are compatible.
>
> You can already use a 0.8 snapshot version if you want:
> http://cargo.codehaus.org/dist2-snapshot
>
> [snip]
>
> Thanks
> -Vincent
>
>

Mime
View raw message