geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Blevins <>
Subject Re: Sample plan bits for configId branch, please review!
Date Wed, 15 Feb 2006 22:04:55 GMT
On Feb 15, 2006, at 1:38 PM, Dain Sundstrom wrote:

> On Feb 15, 2006, at 1:23 PM, David Blevins wrote:
>> So we should call it something like:
>> <configuration>
>> ...
>>   <naming-properties>
>>     <property>
>>       <name>base-name</name>
>>       <value>geronimo.maven:J2EEServer=geronimo</value>
>>     </property>
>>   </naming-properties>
>> ...
>> </configuration>
>> Cause IMHO, having a <configuration> element with a <properties>  
>> sub element implies something all together different:


> Also I would prefer to not imply that these properties are limited  
> to only "naming-properties".  I gut tells me that this will be a  
> useful extension place in the geronimo configurations.

Ok.  I was under the impression via DJ's comments that these were  
only for naming.

On Feb 15, 2006, at 10:59 AM, David Jencks wrote:
> Dain:
>  I'm not sure about the names of name-keys and name-key.  These are  
> really intended for use by the naming system and are rarely used,  
> so I prefer to name them that way rather than "properties".  What  
> could other properties be used for?  How would we distinguish them  
> from the ones for the naming system?

And your comment on using any naming system made me think my  
impression was definitely write.  I guess this isn't one of those  
agreed upon things just yet.

So what is the general idea behind them?  A generic bucket for  
properties that are easily available to all gbeans in my configuration?


View raw message