geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dain Sundstrom <d...@iq80.com>
Subject Re: Sample plan bits for configId branch, please review!
Date Wed, 15 Feb 2006 21:38:15 GMT
On Feb 15, 2006, at 1:23 PM, David Blevins wrote:

> So we should call it something like:
>
> <configuration>
> ...
>   <naming-properties>
>     <property>
>       <name>base-name</name>
>       <value>geronimo.maven:J2EEServer=geronimo</value>
>     </property>
>   </naming-properties>
> ...
> </configuration>
>
> Cause IMHO, having a <configuration> element with a <properties>  
> sub element implies something all together different:
>
> <configuration>
> ...
>   <properties>
>     <property>
>       <name>base-name</name>
>       <value>geronimo.maven:J2EEServer=geronimo</value>
>     </property>
>   </properties>
> ...
> </configuration>

The xml is more like this:

<configuration xmlns="http://geronimo.apache.org/xml/ns/deployment-1.1">
   <environment>
     <configId>
       <groupId>geronimo</groupId>
       <type>car</type>
       <artifactId>geronimo-gbean-deployer</artifactId>
       <version>1.0.1-SNAPSHOT</version>
     </configId>
     <properties>
       <property>
         <name>base-name</name>
         <value>geronimo.maven:J2EEServer=geronimo</value>
       </property>
     </properties>
   </environment>
</configuration>


I think it is fairly clear that these are properties of the  
environment.  Also I would prefer to not imply that these properties  
are limited to only "naming-properties".  I gut tells me that this  
will be a useful extension place in the geronimo configurations.

-dain

Mime
View raw message