geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hernan Cunico <hcun...@gmail.com>
Subject Re: Security Realms - Database SQL type
Date Tue, 28 Feb 2006 23:02:19 GMT
Hi All,
Thanks for the replies. The problem was the capitalization of the password, my mistake :D.
I missed the obvious and focused on the SQL selects.

I initially tried with Derby, but when you test the connection pool (from the creation pool
wizard) 
the test will succeed independently of the user you username, is that right?

As for DB2, I am aware of the limitation with the console and connection pools requiring multiple

files. There is an article in confluence with a manual procedure to workaround this limitation.

Although I have now successfully created a new SQL security realm with DB2 I still fail to
test the 
connection when using Derby, still working on it.

As an additional improvement, it would be nice to have the chance, when you edit an existing

connection pool, to test/re-test the connection after you make any changes to that configuration.

Currently you can only test the connection when you are creating the pool.

Thanks again for the replies.

Cheers!
Hernan

Aaron Mulder wrote:
> Patches to improve error messages would be welcome.  :)
> 
> If you're having problems with the database connections, it may be
> that we should work on getting the database pool working first and
> then attack the SQL realm.  Just be aware that the console can't
> handle database connections if more than one driver JAR is required (I
> think DB2 may have a second license JAR required, but Derby should
> work fine).
> 
> Thanks,
>     Aaron
> 
> On 2/28/06, Hernan Cunico <hcunico@gmail.com> wrote:
> 
>>Hi All,
>>I am trying to set a new security realm using a Database SQL realm type. I tried with
DB2 and the
>>built in Derby, both fail when testing the connection.
>>
>>For DB2 as well as for Derby I created a connection pool first as I have a different
issue from the
>>security realm wizard, it seems not to recognize the JDBC driver class. So far I have
been only
>>using the Admin Console.
>>
>>This is the error I see when try to test a login (it does not say much). Any idea
what I'm missing?
>>
>>Thanks in advance
>>
>>14:22:19,929 WARN  [SecurityRealmPortlet] Test login failed
>>javax.security.auth.login.FailedLoginException
>>        at org.apache.geronimo.security.realm.providers.SQLLoginModule.login(SQLLoginModule.java:199)
>>        at
>>org.apache.geronimo.console.util.KernelManagementHelper.testLoginModule(KernelManagementHelper.java:953)
>>        at org.apache.geronimo.console.util.PortletManager.testLoginModule(PortletManager.java:174)
>>        at
>>org.apache.geronimo.console.securitymanager.realm.SecurityRealmPortlet.actionAttemptLogin(SecurityRealmPortlet.java:308)
>>        at
>>org.apache.geronimo.console.securitymanager.realm.SecurityRealmPortlet.processAction(SecurityRealmPortlet.java:193)
>>        at org.apache.pluto.core.PortletServlet.dispatch(PortletServlet.java:229)
>>        at org.apache.pluto.core.PortletServlet.doGet(PortletServlet.java:158)
>>        at javax.servlet.http.HttpServlet.service(HttpServlet.java:595)
>>        at javax.servlet.http.HttpServlet.service(HttpServlet.java:688)
>>        at org.apache.pluto.core.PortletServlet.service(PortletServlet.java:153)
>>        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
>>        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
>>        at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:672)
>>        at org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:574)
>>        at org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:499)
>>        at org.apache.pluto.invoker.impl.PortletInvokerImpl.invoke(PortletInvokerImpl.java:120)
>>        at org.apache.pluto.invoker.impl.PortletInvokerImpl.action(PortletInvokerImpl.java:68)
>>        at org.apache.pluto.PortletContainerImpl.processPortletAction(PortletContainerImpl.java:164)
>>        at
>>org.apache.pluto.portalImpl.core.PortletContainerWrapperImpl.processPortletAction(PortletContainerWrapperImpl.java:82)
>>        at org.apache.pluto.portalImpl.Servlet.doGet(Servlet.java:227)
>>        at javax.servlet.http.HttpServlet.service(HttpServlet.java:595)
>>        at javax.servlet.http.HttpServlet.service(HttpServlet.java:688)
>>        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
>>        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
>>        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
>>        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
>>        at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:482)
>>        at
>>org.apache.geronimo.tomcat.GeronimoStandardContext$SystemMethodValve.invoke(GeronimoStandardContext.java:272)
>>        at org.apache.geronimo.tomcat.valve.DefaultSubjectValve.invoke(DefaultSubjectValve.java:46)
>>        at org.apache.geronimo.tomcat.valve.PolicyContextValve.invoke(PolicyContextValve.java:50)
>>        at org.apache.geronimo.tomcat.valve.TransactionContextValve.invoke(TransactionContextValve.java:53)
>>        at org.apache.geronimo.tomcat.valve.ComponentContextValve.invoke(ComponentContextValve.java:47)
>>        at org.apache.geronimo.tomcat.valve.InstanceContextValve.invoke(InstanceContextValve.java:60)
>>        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
>>        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
>>        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
>>        at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:526)
>>        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
>>        at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
>>        at
>>org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:744)
>>        at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
>>        at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
>>        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
>>        at java.lang.Thread.run(Thread.java:534)
>>
>>Cheers!
>>Hernan
>>
> 
> 

Mime
View raw message