geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul McMahan <>
Subject Re: Sample plan bits for configId branch, please review!
Date Wed, 15 Feb 2006 15:07:34 GMT
Both options seem pretty equal to me in terms of what they can express but I
like the second option better mostly for stylistic reasons.  Namely, based
on a hunch that typical deployment plans would be less verbose (and
therefore less error prone) using this option.

A few suggestions for the second option:

-   Make the current environment/configId element also be a child of the
dependency element.
    This would help make it clear that the "type", "groupId", "version",
etc. elements describe
    the target of the dependency and not the dependency itself.
-   "scope" seems a bit of a misnomer to me, I think "dependency-type" might
be clearer, or
    you may prefer just "type" if you agree with the previous suggestion
-   For the value of scope (aka dependency-type) I'm concerned that "both"
could be
    misleading since it already has more than two potential values and more
could be added
    later. So I would suggest listing each scope individually.

Here's an example of what the dependency element could look like based on
these suggestions:

Best wishes,

On 2/14/06, David Jencks <> wrote:
> We need some widespread thought about the new xml schema we're
> getting in 1.1.   Dain and I are not particularly thrilled with the
> element names but haven't thought of improvements.  We also thought
> of an alternate way of presenting the info and would like opinions on
> which is better.
> The schema currently in svn in the configid branch results in plans
> that start like this:  [snip]

View raw message