geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conrad O'Dea" <co...@iona.com>
Subject Re: problem building head
Date Thu, 16 Feb 2006 12:15:21 GMT

Hi Kevan, 

things are going better now.  My build is picking up the jar that was
missing before and is progressing (albeit very slowly).

thanks for the help
Conrad 


On Wed, 2006-02-15 at 11:05 -0500, Kevan Miller wrote:
> On Feb 15, 2006, at 10:04 AM, Conrad O'Dea wrote:
> 
> > Hi there,
> >
> > I am having problems getting a build of Geronimo.  I am following the
> > instructions at: http://wiki.apache.org/geronimo/Building
> > I've basically done the following (and several combinations thereof):
> >
> >   % svn co  https://svn.apache.org/repos/asf/geronimo/trunk geronimo
> >   % cd geronimo
> >   % maven m:fresh-checkout
> >   % maven new -Dmaven.test.skip=true -Dmaven.itest.skip=true
> >
> > and after a good healthy time of doing stuff it fails with:
> >
> > "The build cannot continue because of the following unsatisfied
> > dependency:
> >
> > geronimo-j2ee_1.4_spec-1.1-SNAPSHOT.jar"
> >
> > I've also checked-out geronimo-specs and built it with 'mvn  
> > install' but
> > this jar has not been built anywhere in that working copy or either
> > ~/.maven or ~/.m2 repositories.  Nor can I find it in the maven
> > repository at http://cvs.apache.org/repository/geronimo-spec/jars/.
> 
> Conrad,
> I just verified that geronimo-j2ee_1.4_spec-1.1-SNAPSHOT.jar was  
> built and placed in my .maven repository. Can you svn update your  
> specs and try again?
> 
> FYI -- the spec jar was mistakenly deleted from the apache repo. I'm  
> sure it will be back sometime soon.
> 
> Also, I believe there was also a problem in the spec build which  
> didn't put the jar in your .maven repo. I thought that had been fixed  
> over the weekend...
> 
> --kevan
> 


Mime
View raw message