geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Bartel <j...@mortbay.com>
Subject Re: Build errors on trunk
Date Sat, 14 Jan 2006 12:51:49 GMT
David,

I'm ecstatic! Those dependency changes have solved my problems and I
finally have a build.

Thanks heaps!

Jan

David Jencks wrote:
> There were definitely some missing dependencies that explain the  
> possibility of the first problem you encountered.  I'm still confused  
> by the second one.  I've fixed the dependency problems I know about.  
> Can you update and try again?  You should be able to just do:
> 
> rm -rf ~/.maven/repository/geronimo/cars
> maven -o new4
> 
> since everything before this step already worked: removing the cars  
> assures that you will find out if the cars are in fact built in the  
> order they are needed.
> 
> thanks
> david jencks
> 
> On Jan 13, 2006, at 4:54 PM, Jan Bartel wrote:
> 
>> I still can't build HEAD. I am using maven 1.0.2 on Ubuntu Linux with
>> jdk 1.4.2 and svn revision 368935.
>>
>> I've done:
>>
>> + deleted geronimo from my local repo
>> + deleted the plugins from my local repo
>> + deleted configs/*/target
>> + maven m:fresh-checkout
>> + maven m:clean
>> + maven new
>>
>> The build complains as follows:
>>
>> [echo] Running car:install for Welcome app Tomcat
>> 12367 [main] ERROR  
>> org.apache.geronimo.plugin.packaging.PackageBuilder  -  
>> org.apache.geronimo.kernel.config.NoSuchConfigException: No  
>> configuration with id: geronimo/openejb-deployer/1.1-SNAPSHOT/car
>> org.apache.geronimo.kernel.config.NoSuchConfigException: No  
>> configuration with id: geronimo/openejb-deployer/1.1-SNAPSHOT/car
>>
>> If I go into configs/openejb and build it, then restart the build,  it 
>> will fail with the
>> error I posted previously:
>>
>> "Module geronimo/openejb/1.1-SNAPSHOT/car already exists in the  
>> server. Try to undeploy it first or use the redeploy command."
>>
>> This will also happen on some of the other configs.
>>
>> It almost looks like maven has the wrong build order?
>>
>> Jan
>>
>>
>>
>>
>>
>>
>>
>> Aaron Mulder wrote:
>>
>>> I was able to build HEAD successfully.  I did:
>>> maven m:update
>>> maven -o m:clean m:clean-repo
>>> maven new
>>> I used Maven 1.1-beta2 and the last (online) step took 51m.
>>> Aaron
>>> On 1/12/06, Jan Bartel <janb- 
>>> Hmr7moDsS2RBDgjK7y7TUQ-XMD5yJDbdMReXY1tMh2IBg@public.gmane.org> wrote:
>>>
>>>> Anita,
>>>>
>>>> I must admit that I've been trying to build most of it
>>>> offline as it takes me about 8hrs to do a full build online
>>>> (problem with using a laptop).
>>>>
>>>> I have bitten the bullet and am now about 2hrs thru a full
>>>> build, so I will let you know what happens when I get up to
>>>> the openejb portion of the build.
>>>>
>>>> thanks
>>>> Jan
>>>>
>>>>
>>>> anita kulshreshtha wrote:
>>>>
>>>>> Jan,
>>>>>     Did you delete openejb/core? Build openejb online
>>>>> without it.
>>>>> I could not get the core to build.
>>>>>
>>>>> thanks
>>>>> Anita
>>>>>
>>>>>
>>>>> --- Jan Bartel <janb-Hmr7moDsS2RBDgjK7y7TUQ- 
>>>>> XMD5yJDbdMReXY1tMh2IBg-XMD5yJDbdMReXY1tMh2IBg@public.gmane.org> wrote:
>>>>>
>>>>>
>>>>>
>>>>>> Anita,
>>>>>>
>>>>>> Thanks for the suggestion, but it must be something
>>>>>> else
>>>>>> going on, as I already seem to have the
>>>>>>
>>>>>
>>>>> org.apache.geronimo.specs.geronimo-corba_2.3_spec-1.0.jar
>>>>>
>>>>>
>>>>>> in my local repo.
>>>>>>
>>>>>> I'm starting to feel like I may never have a working
>>>>>>
>>>>>> copy again!  :-(
>>>>>>
>>>>>> cheers
>>>>>> Jan
>>>>>>
>>>>>> anita kulshreshtha wrote:
>>>>>>
>>>>>>
>>>>>>>  I have had the same luck! After 2 days I was
>>>>>>
>>>>>>
>>>>>> able
>>>>>>
>>>>>>
>>>>>>> to build the server. This is related to G-1449.
>>>>>>
>>>>>>
>>>>>> The
>>>>>>
>>>>>>
>>>>>>> missing geronimo-corba_2.3_spec-1.0.jar should be
>>>>>>
>>>>>>
>>>>>> put
>>>>>>
>>>>>>
>>>>>>> in maven repo at org.apache.geronimo.specs
>>>>>>
>>>>>>
>>>>>> manually.
>>>>>>
>>>>>>
>>>>>>>      I hope this helps.
>>>>>>>
>>>>>>> Thanks
>>>>>>> Anita
>>>>>>>
>>>>>>> --- Jan Bartel
>>>>>>
>>>>>>
>>>>>> <janb-Hmr7moDsS2RBDgjK7y7TUQ-XMD5yJDbdMReXY1tMh2IBg- 
>>>>>> XMD5yJDbdMReXY1tMh2IBg-XMD5yJDbdMReXY1tMh2IBg@public.gmane.org>
>>>>>> wrote:
>>>>>>
>>>>>>
>>>>>>>> I've been trying to build geronimo trunk for 2
>>>>>>
>>>>>>
>>>>>> days
>>>>>>
>>>>>>
>>>>>>>> and I'm going
>>>>>>>> crazy! I've tried every combination of online and
>>>>>>>> offline, m:clean,
>>>>>>>> m:fresh-checkout, I've even deleted
>>>>>>>> configs/*/target, and I still
>>>>>>>> get this error every time I try and build the
>>>>>>>> configs (this example
>>>>>>>> is from the j2ee-server module, but it happens
>>>>>>
>>>>>>
>>>>>> with
>>>>>>
>>>>>>
>>>>>>>> others too):
>>>>>>>>
>>>>>>>> 8612 [main] ERROR
>>>>>>
>>>>>>
>>>>>>> org.apache.geronimo.plugin.packaging.PackageBuilder
>>>>>>
>>>>>>
>>>>>>>> - org.apache.geronimo.common.DeploymentException:
>>>>>>>> Module geronimo/j2ee-system/1.1-SNAPSHOT/car
>>>>>>
>>>>>>
>>>>>> already
>>>>>>
>>>>>>
>>>>>>>> exists in the server.  Try to undeploy it first or
>>>>>>>> use the redeploy command.
>>>>>>>> org.apache.geronimo.common.DeploymentException:
>>>>>>>> Module geronimo/j2ee-system/1.1-SNAPSHOT/car
>>>>>>
>>>>>>
>>>>>> already
>>>>>>
>>>>>>
>>>>>>>> exists in the server.  Try to undeploy it first or
>>>>>>>> use the redeploy command.
>>>>>>>>
>>>>>>>> Anybody got any clues to help me?
>>>>>>>>
>>>>>>>> TIA
>>>>>>>> Jan
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> __________________________________________________
>>>>>>> Do You Yahoo!?
>>>>>>> Tired of spam?  Yahoo! Mail has the best spam
>>>>>>
>>>>>>
>>>>>> protection around
>>>>>>
>>>>>>
>>>>>>> http://mail.yahoo.com
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>> __________________________________________________
>>>>> Do You Yahoo!?
>>>>> Tired of spam?  Yahoo! Mail has the best spam protection around
>>>>> http://mail.yahoo.com
>>>>>
>>>>
>>>>
>>
> 
> 


Mime
View raw message