geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sachin Patel (JIRA)" <>
Subject [jira] Commented: (GERONIMODEVTOOLS-45) NPE when publishing to Geronimo server
Date Thu, 12 Jan 2006 16:23:21 GMT

Sachin Patel commented on GERONIMODEVTOOLS-45:

Kathy, keep in mind the Module Application_ID already exists in the server error is due to
the two project conflict w/ same config ID's issue.  Even though your workspace may be clean,
the server may be running with a project with that ID.  So could you try on a fresh server
and workspace to see how best to reproduce the NPE?


> NPE when publishing to Geronimo server
> --------------------------------------
>          Key: GERONIMODEVTOOLS-45
>          URL:
>      Project: Geronimo-Devtools
>         Type: Bug
>  Environment: Windows XP
>     Reporter: Kathy Chan
>     Priority: Critical

> Driver used:  WTP 1.0, Geronimo 1.0 server, Geronimo 01/09 plugins
> After installing Geronimo server runtime and creating a Geronimo server using WTP (there's
no other project or EAR on the server):
> - New ->Web Services -> Web Service client
> - Click Next
> - On the Web Service selection page, paste the following in the URI field at the top
of the page:
> - Click Next.
> - In the Client Environment Configuration page, enter a name for a new Web project and
EAR project.  The Web service runtime should be "Apache Axis" and server should be "Apache
Geronimo 1.0".
> - Click Finish would result in:
> Publishing failed
>   Could not publish to the server.
>       java.lang.NullPointerException
>       at org.apache.geronimo.core.commands.DeploymentCmdStatus.isOK(
>       at org.apache.geronimo.core.internal.GeronimoServerBehaviour.doRedeploy(
>       at org.apache.geronimo.core.internal.GeronimoServerBehaviour.invokeCommand(
>       at org.apache.geronimo.core.internal.GeronimoServerBehaviour.publishModule(
>       at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publishModule(
>       at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publishModules(
>       at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(
>       at org.eclipse.wst.server.core.internal.Server.doPublish(
>       at org.eclipse.wst.server.core.internal.Server.publish(
>       at$
>       at org.eclipse.jface.operation.ModalContext$

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message