geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Jencks (JIRA)" <...@geronimo.apache.org>
Subject [jira] Commented: (GERONIMO-1455) System Modules portlet - Start of CAR does not start its GBeans
Date Fri, 13 Jan 2006 17:48:20 GMT
    [ http://issues.apache.org/jira/browse/GERONIMO-1455?page=comments#action_12362676 ] 

David Jencks commented on GERONIMO-1455:
----------------------------------------

It sounds like the console is calling the wrong method.  To start the gbeans in a config,
you need to call configurationManager.loadGBeans, then configurationManager.startGBeans.

> System Modules portlet - Start of CAR does not start its GBeans
> ---------------------------------------------------------------
>
>          Key: GERONIMO-1455
>          URL: http://issues.apache.org/jira/browse/GERONIMO-1455
>      Project: Geronimo
>         Type: Bug
>   Components: console
>     Versions: 1.0
>  Environment: AG 1.0 on WinXP with Sun 1.4.2_08
>     Reporter: Donald Woods
>     Priority: Critical
>      Fix For: 1.0.1

>
> Start AG 1.0 with Log4j logging set to Debug.
> Login in to Console.
> Open System Modules portlet.
> Select Start for geronimo/j2ee-corba/1.0/car.  It shows it as started in the Console
and the state as Running in the logfile, but there is no output from CSSBean, SunORB or OpenEJB
since the Server and UnprotectedServer GBeans were not actually started.
> Shutdown server.
> Start Server.
> The geronimo/j2ee-corba/1.0/car is started and port 1050 is now active.
> In the geronimo.log, there are now CSSBean, SunORB and OpenEJB log statements, since
the Server and UnprotectedServer GBeans were loaded and started.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message