geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dave Colasurdo (JIRA)" <...@geronimo.apache.org>
Subject [jira] Updated: (GERONIMO-1540) Fix security vulnerability in jsp-examples
Date Wed, 25 Jan 2006 21:13:10 GMT
     [ http://issues.apache.org/jira/browse/GERONIMO-1540?page=all ]

Dave Colasurdo updated GERONIMO-1540:
-------------------------------------

    Component: sample apps
      Version: 1.0.1
               1.1

> Fix security vulnerability in jsp-examples
> ------------------------------------------
>
>          Key: GERONIMO-1540
>          URL: http://issues.apache.org/jira/browse/GERONIMO-1540
>      Project: Geronimo
>         Type: Bug
>   Components: sample apps
>     Versions: 1.0.1, 1.1
>     Reporter: Dave Colasurdo

>
> Oliver Karow has reported a cross-site scripting vulnerability in the Tomcat jsp-examples
that are included in Geronimo.  It fails on both Jetty and Tomcat.
> This can be reproduced with the following urls:
> http://localhost:8080/jsp-examples/cal/cal2.jsp?time="/><script>alert('Gotcha')</script>
> http://localhost:8080/jsp-examples/cal/cal2.jsp?time="/><script>alert(document.cookie)</script>
> This JIRA does not address a related problem in the admin console.  That problem is addressed
in GERONIMO-1474.
>  

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message