geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: Cutting Versions for TranQL (TranQL, Connectors and Vendors)
Date Sat, 03 Dec 2005 00:16:50 GMT
Are we sure apache policy allows us to ship the tranql connectors that 
depend on non-open-source stuff in order to compile?  I don't think 
this is clear and think we might want to wait and try to clarify it at 
apachecon.

thanks
david jencks

On Dec 2, 2005, at 1:12 PM, Matt Hogstrom wrote:

> We should have:
>
> Derby (client and embedded) XA
> DB2 XA
> Oracle XA
>
> Jeremy said he was working on a MySQL XA driver.
>
> Matt
>
> Aaron Mulder wrote:
>> Sounds good -- but can you recap the XA drivers that we'll ship with? 
>> Last I heard there was some Oracle code, you've mentioned DB2, and
>> someone got MySQL working, but right this minute I think Geronimo only
>> ships with the Derby XA integration, right?  I'm hoping we can include
>> more for 1.0.
>> Thanks,
>>     Aaron
>> On 12/2/05, Matt Hogstrom <matt@hogstrom.org> wrote:
>>> I would like to cut a release of TranQL sometime in the next few 
>>> days (perhaps
>>> Monday).  There has not been a lot of activity in TranQL as of late 
>>> so there is
>>> no major code going in. In the Vendors and Connector I'm 
>>> experimeting with a few
>>> changes.
>>>
>>> In Vendors I've added connectors for DB2 as an additional vendor.  I 
>>> haven't
>>> fully tested it out but that shouldn't impact CTS as we're only 
>>> certifying with
>>> Derby.
>>>
>>> In the Connector framework I'm working on a statement caching 
>>> DataSource.
>>> Again, this does not affect G directly as the Derby code is not 
>>> being modified
>>> (to the best of my knowledge).
>>>
>>> If anyone has any concerns please respond back.
>>>
>>> The new versions will be:
>>>
>>> TranQL    1.2
>>> Connector 1.1
>>> Vendors   1.1
>>>
>>> Cheers,
>>>
>>> Matt
>>>
>>>
>


Mime
View raw message