geronimo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Genender <jgenen...@apache.org>
Subject Re: An issue about TomcatGeronimoRealm
Date Fri, 30 Dec 2005 16:59:13 GMT
Hi Jian,

I am sorry, I had to read your problem closer to get the gist of the
problem...so here is a second go on this:

Upon closer inspection of this...

/jetspeed/* should be picked up fine in the getServletName().  Upon
running some tests, it seems fine.

You stated your web app context is named "jetspeed", and thus this is
probably causing your problem.  Since you called it "jetspeed", this is
the context portion and thus is not part of the relative URI.  Thus, the
http://localhost:8080/jetspeed/ URL's relative URI truly is "default" or
"/".

With that context name, the way you will get this to work in your
configuration is with this URL:

http://localhost:8080/jetspeed/jetspeed/

If you want http://localhost:8080/jetspeed/ to work, then you must set
the context-root to <context-root>/</context-root> in your
plan/geronimo-web.xml.

Jeff


Jeff Genender wrote:
> Remove the forward slash and it will give you what you are looking for.
> 
> Please try this:
> 
> <servlet-mapping>
>        <servlet-name>jetspeed</servlet-name>
>        <url-pattern>jetspeed/*</url-pattern>
> </servlet-mapping>
> 
> 
> Jian Liao wrote:
>> Hi all,
>> I am running Jetspeed on geronimo-tomcat-j2ee-1.0-2005-12-22. My jetspeed
>> web app context is jetspeed and I also have a servlet named   "jetspeed"
>> defined in web.xml. When there is request for url:
>> http://localhost:8080/jetspeed/. The private method getServletName(Request
>> request) defined in TomcatGeronimoRealm will return a "default" string, is
>> that what it expects?(I know default is configured by tomcat,
>> http://tomcat.apache.org/tomcat-5.5-doc/default-servlet.html)
>> Why it does not return "jetspeed", I did have a servlet named that. The
>> following is a snippet from my web.xml.
>>
>> <servlet>
>>     <servlet-name>jetspeed</servlet-name>
>>     <servlet-class>org.apache.jetspeed.engine.JetspeedServlet
>> </servlet-class>
>>     <init-param>
>>       <param-name>properties</param-name>
>>       <param-value>/WEB-INF/conf/jetspeed.properties</param-value>
>>     </init-param>
>>     <init-param>
>>       <param-name>applicationRoot</param-name>
>>       <param-value>webContext</param-value>
>>     </init-param>
>>     <load-on-startup>1</load-on-startup>
>>   </servlet>
>> ......
>> <servlet-mapping>
>>        <servlet-name>jetspeed</servlet-name>
>>        <url-pattern>/jetspeed/*</url-pattern>
>> </servlet-mapping>
>>
>> Any help would be appreciated!
>>
>> - Jian Liao
>>
> 

Mime
View raw message